No Electric - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
V-Strom Service and Maintenance Questions and Discussions Share your service and maintenance information-questions. Please include your year and model in the text of your post.

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 10-21-2010, 03:22 PM Thread Starter
Stromthusiast!
 
Join Date: Apr 2009
Location: Treasure Coast FL
Posts: 37
No Electric

Having electrical issues with my 08 DL1000. Riding on Sunday and made 2 stops. Everything going well until trying to leave my 3rd stop of the day. Inserted the key turned the ignition and.... nothing. No gauges, no fuel pump whine etc... Trailored bike home. First thought was battery so tested and charged the battery (was already at about 80% charge). Still nothing. Checked fuses, all are intact. Not sure where to start at this point. Thinking ignition switch maybe?? Would appreciate any suggestions. Working the next few days but want to get on this my next day off. Driving me nuts that the riding weather has been perfect and I'm bikeless at the moment

[SIGPIC][/SIGPIC]
NightGator is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 10-21-2010, 04:50 PM
Stromthusiast!
 
ozart's Avatar
 
Join Date: Sep 2009
Location: Texas
Posts: 3,879
Here's the possible connection problem areas to the ignition switch.
battery connections
main fuse 30a
black/red wire
ignition switch connector
ignition switch
ozart is offline  
post #3 of 3 Old 10-25-2010, 11:30 PM Thread Starter
Stromthusiast!
 
Join Date: Apr 2009
Location: Treasure Coast FL
Posts: 37
Thanks. Ended up being the 30 amp fuse. It blew a 2nd time and I noticed it only happened when I turned the handlebars all the way right. Finally clicked that since putting on risers the various cables were a little tighter than before when in a full turn and discovered that the tension had created a short in the cable coming off of the ignition. Problem solved.....

[SIGPIC][/SIGPIC]
NightGator is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome