Water Pump Questions - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
V-Strom Service and Maintenance Questions and Discussions Share your service and maintenance information-questions. Please include your year and model in the text of your post.

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 09-14-2009, 02:56 PM Thread Starter
Stromthusiast!
 
Join Date: Sep 2006
Location: White Post, VA
Posts: 51
Water Pump Questions

All,

Sorry for asking about something that I know has already been covered somewhere, but I can't find the previous posts on this topic.

I have the dreaded "puddle of antifreeze under the bike when parked" issue. It's under the weep tube, so I assume the water pump is leaking. I think I read in a previous post that this could either be the O ring or the seals. Is this accurate?

If so, it appears on the fiche that the O ring can be replaced by just pulling the water pump cover, but that you may have to split the engine to pull the impeller and replace the seal. Is this accurate as well?

Thanks in advance for any advice on this topic,

John J.

John Jenkins
DL1000 K4
jjenkins334 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 09-14-2009, 09:39 PM
$tromtrooper
 
568v8's Avatar
 
Join Date: Feb 2008
Location: Kingston, Ontario
Posts: 1,609
Garage
Could it be the over flow tube ?

Road Toads Charter Member - old guy goes stromabout on a 2007 Vee and finally has touched all of the 48 contiguous United states and the 10 Canadian provinces.
568v8 is offline  
post #3 of 4 Old 09-14-2009, 10:01 PM
 
Join Date: Apr 2006
Posts: 1,376
Quote:
Originally Posted by jjenkins334 View Post
All,

Sorry for asking about something that I know has already been covered somewhere, but I can't find the previous posts on this topic.

I have the dreaded "puddle of antifreeze under the bike when parked" issue. It's under the weep tube, so I assume the water pump is leaking. I think I read in a previous post that this could either be the O ring or the seals. Is this accurate?

If so, it appears on the fiche that the O ring can be replaced by just pulling the water pump cover, but that you may have to split the engine to pull the impeller and replace the seal. Is this accurate as well?

Thanks in advance for any advice on this topic,

John J.
John its a easy repair and no you do not have to split the engine I would suggest you buy a manual first then follow the instructions. There are two seals, replace both while you are there.
Mortaine is offline  
 
post #4 of 4 Old 09-15-2009, 10:43 AM Thread Starter
Stromthusiast!
 
Join Date: Sep 2006
Location: White Post, VA
Posts: 51
Thanks for the advice. I have part of the maint manual that I downloaded when it was on line, but think it's time to go ahead and pick up the whole thing.

I've done quite a bit of work on cars (pulling trannies, etc.), but for some reason I'm a little hesitant to dig into the guts of the Vee. I guess this will be the next step in overcoming my phobia!

John Jenkins
DL1000 K4
jjenkins334 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome