no speedo - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
V-Strom Service and Maintenance Questions and Discussions Share your service and maintenance information-questions. Please include your year and model in the text of your post.

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 07-27-2009, 05:04 PM Thread Starter
Stromthusiast!
 
webbhead2's Avatar
 
Join Date: May 2007
Location: Aurora, IL
Posts: 22
Send a message via Yahoo to webbhead2 Send a message via Skype™ to webbhead2
no speedo

ive got no speedo OR odometer, but the tach still works. any ideas???

its not about [COLOR="Red"]WHAT[/COLOR] you ride, but [COLOR="red"]IF[/COLOR] you ride
webbhead2 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 07-27-2009, 05:20 PM
$tromtrooper
 
silverstrom's Avatar
 
Join Date: Jun 2007
Location: Near Tweed Ontario
Posts: 1,458
650 or 1000? The speedo drives are different.

If it's a 650 a good place to start is by checking the drive gear at the front wheel. They can cause problems and occasionally require some lubrication.

The 1000 I'm not sure about, but I think the speedo drive comes from the front sprocket.


SS

DL650K7
1985 RZ500
1986 NS400R HRC
1987 RG250
1987 TZR 250
1988 RGV 250
1989 RZ 350 F2
1990 RZ 350 N2

Last edited by silverstrom; 07-27-2009 at 05:25 PM.
silverstrom is offline  
post #3 of 5 Old 07-27-2009, 08:40 PM Thread Starter
Stromthusiast!
 
webbhead2's Avatar
 
Join Date: May 2007
Location: Aurora, IL
Posts: 22
Send a message via Yahoo to webbhead2 Send a message via Skype™ to webbhead2
it is a 1000... im thinking the drive is of the trans or sprocket also. there is no drive on the front wheel...

its not about [COLOR="Red"]WHAT[/COLOR] you ride, but [COLOR="red"]IF[/COLOR] you ride
webbhead2 is offline  
 
post #4 of 5 Old 07-27-2009, 09:47 PM
Stromthusiast!
 
randyo's Avatar
 
Join Date: Dec 2006
Location: Farmington, New Hampshire, USA
Posts: 10,196
I'd check around the sprocket cover to see is any wiring is unplugged or broken



Never pay again for live sex! | Hot girls doing naughty stuff for free! | Chat for free!

RandyO
IBA# 9560
07 Strom 1k (8x,xxx miles)
99 SV650 (135,006 miles)
82 XV920R
A man with a gun is a citizen
A man without a gun is a subject
www.gbhsurvey.com
randyo is offline  
post #5 of 5 Old 07-28-2009, 09:04 PM Thread Starter
Stromthusiast!
 
webbhead2's Avatar
 
Join Date: May 2007
Location: Aurora, IL
Posts: 22
Send a message via Yahoo to webbhead2 Send a message via Skype™ to webbhead2
i checked that. pulled the sensor out and cleaned it off. still nothing...

its not about [COLOR="Red"]WHAT[/COLOR] you ride, but [COLOR="red"]IF[/COLOR] you ride
webbhead2 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome