Front turn signals not lighting - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
V-Strom Service and Maintenance Questions and Discussions Share your service and maintenance information-questions. Please include your year and model in the text of your post.

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 07-15-2009, 12:44 AM Thread Starter
Stromthusiast!
 
Join Date: May 2009
Location: Las Vegas, Nevada
Posts: 21
Question Front turn signals not lighting

Hi there! My name is Paul and I was going to introduce myself
in the new member section but I ran into a problem with my
DL650. I purchased this bike one month ago as a salvage and
I just finished putting it back together last night. The bike is
an '05 model with an '04 frame. I purchased some aftermarket
turnsignals for the front and connected them last night. At first
when I tested them both turnsignals worked. After finishing the
final install onto the fairing, the signals are now not working. I tested
the front signals tonight by plugging them into the rear turn signal
connections and both front signals worked. The bike has a new battery.
Any ideas or suggestions?

One more thing, my brake light is not working. Both the front brake
and the rear brake light will not light, any clues to this one?

I checked all the small fuses, they are all good. The bike starts
and runs fine.
Norstrom is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 07-16-2009, 03:16 PM Thread Starter
Stromthusiast!
 
Join Date: May 2009
Location: Las Vegas, Nevada
Posts: 21
Well, I am answering my own questions, which is not bad after all
since I learned something from this. I had crossed the wires on one
of the front turn signals, after re-installation they work great.

Regarding the brake light not working, the connection for the wires to
the rear brake pedal was not screwed in far enough and the brake
light now works as well.

Pictures to follow in the new member section.
Norstrom is offline  
post #3 of 3 Old 07-16-2009, 10:32 PM
$tromtrooper
 
silverstrom's Avatar
 
Join Date: Jun 2007
Location: Near Tweed Ontario
Posts: 1,458
Welcome to the site Paul!

Glad we could help


SS

DL650K7
1985 RZ500
1986 NS400R HRC
1987 RG250
1987 TZR 250
1988 RGV 250
1989 RZ 350 F2
1990 RZ 350 N2
silverstrom is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome