Phone won’t charge from usb charger - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
V-Strom Service and Maintenance Questions and Discussions Share your service and maintenance information-questions. Please include your year and model in the text of your post.

 
LinkBack Thread Tools Display Modes
post #1 of 10 Old 06-26-2018, 04:40 PM Thread Starter
Stromthusiast!
 
Join Date: Jan 2017
Location: San Francisco Bay Area
Posts: 20
Phone won’t charge from usb charger

A couple of months ago I put in one of those Eastern Beaver PC8 boxes. I bought a compressor and that runs fine off the SAE plug from there. I also have a Trackside USB port, and while I thought I had verified it works to charge the phone, I discovered a day into this three week trip from San Francisco to Denver and back that it’s definitely not charging my iPhone *now*.

I’m in Denver for a few days so I have a little time to look at it. I’ve googled and haven’t seen anything helpful yet. Any ideas to what I might have going wrong? The fact that the compressor still runs fine is confusing me.
kgoess is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 06-26-2018, 04:52 PM
Stromthusiast!
 
stuball's Avatar
 
Join Date: Mar 2018
Location: Northern/ Central California
Posts: 126
Garage
Have you verified the Charger works, IE; plugging into Car ?? Sometimes those chargers can be faulty...
stuball is offline  
post #3 of 10 Old 06-26-2018, 05:45 PM Thread Starter
Stromthusiast!
 
Join Date: Jan 2017
Location: San Francisco Bay Area
Posts: 20
I don’t have any SAE plugs around besides the ones on the bike which don’t work. I’ll definitely try buying a second one if I can find one here in Denver.
kgoess is offline  
 
post #4 of 10 Old 06-26-2018, 05:48 PM
Stromthusiast!
 
BC Rider's Avatar
 
Join Date: May 2014
Location: Okanagan Valley, British Columbia
Posts: 309
Hot and ground reversed on back of unit? Ignition on if it is not on the always on circuit?

13 DL650 Current ride
80 CX500D
77 XS360
78 XS750
76 CB360T
BC Rider is offline  
post #5 of 10 Old 06-26-2018, 05:58 PM
Stromthusiast!
 
PerazziMx14's Avatar
 
Join Date: Aug 2016
Posts: 1,284
Don't worry a buddy of mine has a Battery Tender SAE to USB plug fail about 2 hours into our week long trip. Fortunately just about every auto parts store or big box store has 12v USB ports or battery packs to get you going again.
PerazziMx14 is offline  
post #6 of 10 Old 06-26-2018, 07:34 PM
Stromthusiast!
 
PineLaneRider's Avatar
 
Join Date: Aug 2016
Location: South Central PA
Posts: 324
Garage
I've had 2 of these fail after forgetting to put the cover on and having a rain shower. I have taken to carrying a replacement in my top box, just in case. I think I paid $7.99 a piece for them so it isn't devastating, but its very inconvenient when it fails!
PineLaneRider is online now  
post #7 of 10 Old 06-26-2018, 08:40 PM Thread Starter
Stromthusiast!
 
Join Date: Jan 2017
Location: San Francisco Bay Area
Posts: 20
Well the local auto parts stores didn’t have SAE to USB, so I bought an SAE to cigarette lighter and bought a cigarette lighter to USB. Still no dice. I plug in the phone and nothing happens. I’ll go to the hardware store tomorrow and buy some electrical testers, or see if I can figure out how to post photos on here.
kgoess is offline  
post #8 of 10 Old 07-14-2018, 03:23 PM Thread Starter
Stromthusiast!
 
Join Date: Jan 2017
Location: San Francisco Bay Area
Posts: 20
After further investigation, it turns out I had the SAE plugs wired in backwards?? The SAE pigtails have a red wire and a grey wire, and I assumed the red wire would go into the hot side of my PC-8 box, but no! I fried a bunch of USB connectors before I figure it out.

Oh, I see, if I even bothered to read wikipedia

"The polarity of the connector, when installed in a vehicle and attached to a battery, is always such that no short circuit will occur if the exposed terminal were to touch the vehicle chassis. In most vehicles, this means that the exposed terminal connects to the negative terminal of the battery."
https://en.wikipedia.org/wiki/DC_con...#SAE_connector
Attached Images
File Type: jpg IMG_0407.jpg (343.7 KB, 2 views)
kgoess is offline  
post #9 of 10 Old 07-14-2018, 03:35 PM
$tromtrooper
 
Join Date: Feb 2013
Location: SE Ohio
Posts: 216
it its mini usb make sure the actual connector works with your phone. I have a Samsung phone that is sensitive to the length of the mini usb connector. It wasn't charging when I plugged it in so I switched to a new usb and it was fine. You could verify if there is poser to the cord w/ a volt meter.

Current: '12 Dl650, '06 ST1300, '89 Transalp, '84 XL350R, '07 TRX350TM,
DownOnTheFarm is offline  
post #10 of 10 Old 07-14-2018, 04:46 PM
Stromthusiast!
 
Hank122's Avatar
 
Join Date: Nov 2015
Location: Massachusetts, USA
Posts: 725
I've been using the dedicated (hard wired) USB charger for a while now as well as the cigarette lighter style for my other needs (mini compressor, etc).
Adventure Tech sells the dedicated ones, they have both a 1 amp and 2.1 amp connectors.
Attached Images
File Type: jpg usb.jpg (5.3 KB, 18 views)

Henry

"Rock bottom will teach you lessons that mountain tops never will..."

2016 V-Strom DL650 (red) 'Sweetness'
2011 V-Strom DL650 (white)

Last edited by Hank122; 07-14-2018 at 04:49 PM.
Hank122 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome