turned the key and NOTHING....... - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
V-Strom Service and Maintenance Questions and Discussions Share your service and maintenance information-questions. Please include your year and model in the text of your post.

 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 05-26-2009, 07:48 PM Thread Starter
Stromthusiast!
 
webbhead2's Avatar
 
Join Date: May 2007
Location: Aurora, IL
Posts: 22
Send a message via Yahoo to webbhead2 Send a message via Skype™ to webbhead2
turned the key and NOTHING.......

i went out today to start my '05 dl 1000... when i turn the key... nothing happend... no lights no horn no alarm... nothing.

tried to jump it... (i know this is bad for the battery) and still nothing doing..

took the battery out. load tested it... BAD... volt tested it... DEAD... so i got a new battery...

came home, put it in, turned the key..... NOTHING.... like before.

any ideas, suggestions... HELP???

i ride daily, rain, shine, hot, cold. people think im nuts... but at this point its my only transportation...

thanks in advance...

its not about [COLOR="Red"]WHAT[/COLOR] you ride, but [COLOR="red"]IF[/COLOR] you ride
webbhead2 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 05-26-2009, 08:04 PM
Stromthusiast!
 
Join Date: Dec 2008
Location: Pacific Northwet
Posts: 651
Did you check the fuses?

DL1000K8

So what is it, am I a smart*** or a dumb***? Maybe I'm just an ***hole.
10guy is offline  
post #3 of 7 Old 05-26-2009, 08:19 PM
Stromthusiast!
 
Join Date: Apr 2008
Location: Sun Prairie, WI
Posts: 148
Kill switch?
dsm_rally is offline  
 
post #4 of 7 Old 05-26-2009, 08:50 PM
Stromthusiast!
 
Bamaboy's Avatar
 
Join Date: Jul 2008
Location: Ohio
Posts: 544
Did you put it in N and pull in the clutch? I know stupid question but I have forgotten things like that before.

2004 Silver V-Strom 1000 & 1994 Yamaha XT600

Farkles? Sargent Seat, Genmar risers, K&N filter, cramp buster, heated grips, PCIII, Givi Engine Guards, Givi Hard Bags 52 liter and two 45 liter, Givi shield with spacers for buffeting.

[SIGPIC][/SIGPIC]
Bamaboy is offline  
post #5 of 7 Old 05-26-2009, 10:35 PM
Stromthusiast!
 
Join Date: Dec 2007
Location: Canberra, Australia
Posts: 486
Check the fuses as said above.

This happened to me about a month ago, I had assumed it was the battery as it was a couple of years old and i hadn't ridden it for about 5 days. I thought my son turned the alarm on with the remote.
Anyway, I went and got the battery checked before buying a new one, it had 12+volts and held a 12+volts under load. So it wasn't the battery.....
Could have saved a trip if I looked at my fuses, one of the 30amp fuses had blown, 2 sec fix.
choccoloco is offline  
post #6 of 7 Old 05-27-2009, 01:02 AM Thread Starter
Stromthusiast!
 
webbhead2's Avatar
 
Join Date: May 2007
Location: Aurora, IL
Posts: 22
Send a message via Yahoo to webbhead2 Send a message via Skype™ to webbhead2
Talking GOT IT!!

yeah you know im an old harley guy and didnt know for sure if there was a MAIN fuse between all the other fuses... i checked the fuses first and found them all to be good. but thought later that there MUST be a main fuse somewhere... so i looked in the owners manual, and there it was... NOT by the other fuses... WHY??

anyway... its fixed thanks a bunch for your input. i know i can always count on my fellow troopers.....

its not about [COLOR="Red"]WHAT[/COLOR] you ride, but [COLOR="red"]IF[/COLOR] you ride
webbhead2 is offline  
post #7 of 7 Old 05-27-2009, 01:53 AM
Stromthusiast!
 
Join Date: Dec 2008
Location: Pacific Northwet
Posts: 651
Your welcome

DL1000K8

So what is it, am I a smart*** or a dumb***? Maybe I'm just an ***hole.
10guy is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome