new oem grip heaters quit - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
V-Strom Service and Maintenance Questions and Discussions Share your service and maintenance information-questions. Please include your year and model in the text of your post.

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 12-24-2005, 05:07 PM Thread Starter
Stromthusiast!
 
Join Date: Dec 2005
Location: cda, id
Posts: 22
new oem grip heaters quit

Merry Christmas! I bought my slightly used (620 miles) wee strom nov 22. It snowed the next day and the roads have been snow packed since. Well a heat wave has come and I got to ride it finally for the first time today. I love it except the part when the new heated oem grips that the dealer put on for me quit 20mins into the ride. Is there a fuse or easy answer or will I have to take it back to the dealer.
northidaho is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 12-24-2005, 05:24 PM Thread Starter
Stromthusiast!
 
Join Date: Dec 2005
Location: cda, id
Posts: 22
got em too hot

I think I figured it out. After I left the bike for a while, I came back out and fired it up and the grips worked. Did I let them get too hot and they shut themselves off like a hair dryer or vaccum if it is on too long. Thanks
northidaho is offline  
post #3 of 4 Old 12-24-2005, 08:57 PM
Stromthusiast!
 
Join Date: Feb 2004
Posts: 504
Hey northidaho, are you the one that bought that blue weeStrom at Camp Motorsports? Or did Beaudry have one that I didn't see? In any event, you will really like the Strom. I have over 20,000 on my blue weeStrom and it runs like a top.

Yeah, that was pretty strange weather today, almost 50 degrees here in the Spokane Valley.

Dan

http://community-2.webtv.net/CHERDAN...omAccessories/
trailbuster30 is offline  
 
post #4 of 4 Old 12-25-2005, 11:50 PM Thread Starter
Stromthusiast!
 
Join Date: Dec 2005
Location: cda, id
Posts: 22
yes, camp motorsports

Yes, I got the blue one Camp had sitting in the back. I really like the bike (all 17miles around the neighborhood) but the grips thing has me irritated. One of the other fourms is pointing to a possible bad heat controller. I'll take it back if the weather holds and have them look at it as they installed it. May have to hook up with you in the spring and go for a ride.
northidaho is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome