brake light failure - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
V-Strom Service and Maintenance Questions and Discussions Share your service and maintenance information-questions. Please include your year and model in the text of your post.

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 04-27-2005, 12:41 AM
Joe S.
Guest
 
Posts: n/a
brake light failure

For some odd reason the brake lights on my 650 Strom decided to quit working. The taillights are on so I doubt if its the bulbs. Both front and back brakes are not working. Since the fuse involved sereves multiple purposes I'm sure its not that.
Anyone encountered this one yet?
I imagine its going to the dealer tomorrow since its under warranty. Heck this is claim number two in just about 2k miles. Beginning to think there is more similarity to my BMW than I thought. :lol:
Sponsored Links
Advertisement
 
post #2 of 4 Old 04-27-2005, 10:45 PM
Stromthusiast!
 
Join Date: Sep 2004
Location: 44 05' N 71 09' W
Posts: 441
Joe,

Have you inspected the bulbs? The brake and tail lights use separate filiments. Yeah there are two bulbs and what's the chance they could both be burnt out? I dunno but crazier things have happened. I'd pull both bulbs and ohm them out to see if you have continuity through both contacts. If they are good, I'd test for voltage at either or both socktets with power on and either brake applied.

You could of course let the dealer fix it and probably should but I am one of those guys who's too curious to wait long enough for the dealer to get around to it.

Good luck in any event, you gotta have brake lights! Ride well,

Jeff

'06 DL-1000
'06 KLX 250S (more fun than people should be allowed to have)
'72 SL-350 K2 (bump start only)
'72 CL-350 (on injured reserve list at this time)

I guess it's better to bend a valve in Missoula than to lose your mind in Bozeman.

-Barb Egan
MWValley is offline  
post #3 of 4 Old 04-28-2005, 01:02 AM
Joe S.
Guest
 
Posts: n/a
I didn't bother testing anything. I thought about it but the dealer thought they could work it in quickly so I thought I'd just let them have at it.
I think it is statistically possible it could be just the brake fillaments on both bulbs but pretty darn unlikely, nevertheless it would be the place to start if you were going to do diagnosis.
I shouldn't be so lazy and do some of this stuff, but I bought a new one partly for the convenience of warranty. Got to spend my free time wisely you know, like riding the other bikes and net surfing. :wink:
 
post #4 of 4 Old 04-28-2005, 10:11 AM
Stromthusiast!
 
Join Date: Sep 2004
Location: 44 05' N 71 09' W
Posts: 441
Joe,

You are quite correct. You paid for a warranty and by golly you ought to use it if you need it.

The only reason I even thought both bulbs could be out is that years ago...
my car had no low beams all of a sudden. Hmm I thought, the lows couldn't BOTH have burned out at the same time. So I bought and installed a new dimmer switch. Guess what? I still had no low beams. Both bulbs had burnt out at the same time or very close to it.

Have the dealer fix you brake lights and ask them nicely to be quick about it.

Have fun!

Jeff

'06 DL-1000
'06 KLX 250S (more fun than people should be allowed to have)
'72 SL-350 K2 (bump start only)
'72 CL-350 (on injured reserve list at this time)

I guess it's better to bend a valve in Missoula than to lose your mind in Bozeman.

-Barb Egan
MWValley is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome