Race Tech Emulators - Post-installation questions - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
V-Strom Modifications and Performance The brag page, good and bad.

 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 09-09-2006, 11:25 PM Thread Starter
Stromthusiast!
 
Join Date: May 2005
Location: Ottawa (Kanata), Canada
Posts: 269
Race Tech Emulators - Post-installation questions

Thanks to Aircavm his pair of hands and his air tools, today I (we) installed the RT Emulators on my '05.

What was rather odd is the fact that the emulators did not sit properly on the dampening rods. They actually rocked a little with about 1 or 2mm space.

It was necessary to take a grinding stone and etch away part of the surface inside the top of the rod.

The part was S4301, as recommended by Race Tech.

Has anyone else encounted a similar problem?

Also, I didn't measure the height of the oil. With the Sonic springs installed, ended up putting about 475 ml in each tube as some found it's way on the garage floor. Any foreseen problems with this? (After a test run, they seem to be working well and they absorb much more of the irregular sufaces than before).

Cheers,

-lajaro

Blue DL650K5
lajaro is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome