Tool tube bracket - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
V-Strom Modifications and Performance The brag page, good and bad.

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 11-02-2010, 10:10 AM Thread Starter
Stromthusiast!
 
Join Date: Apr 2008
Location: L.A.of,Colorado
Posts: 900
Tool tube bracket

I broke my Dan Vessel tool tube bracket. Overloaded it with a water bottle in the tool tube, and a washboarded road. So anyone beef this up so it can handle the abuse? It's made from pretty thin walled tubing, so welding on it could be tricky.
oldmanb777 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 11-02-2010, 11:00 PM Thread Starter
Stromthusiast!
 
Join Date: Apr 2008
Location: L.A.of,Colorado
Posts: 900
Welded it back together today, and added a doubler. I think not putting heavy things in it is the answer. A water bottle and washboarded roads killed it.
oldmanb777 is offline  
post #3 of 4 Old 11-04-2010, 09:22 PM
Stromthusiast!
 
Join Date: Feb 2004
Posts: 504
I was notified of your dilemna by another Stromer on this site. Your storage tube guard is the 3rd one I have heard of that has cracked near the crimped end in almost 5 years we've been producing them. But those two were enough that I instituted a fix for this a few months ago and it was actually quite simple. On the standard sized tubing we inserted a steel 1/8" insert into both ends of the tubing, extending past the crimped area, just prior to crimping. This in effect beefs up both mounting points of the storage tube luggage guard, as well as the Agri-Tube luggage guard. Initially I started using a larger diameter, 3/4", tubing to remedy this possible condition but found it was overkill, appearing too large when mounted to the Strom.


I have replaced the other two guards at no charge and would be happy to send you a replacement if you would like, just email me at [email protected] and we'll get a replacement in the works for you.


I look forward to hearing from you soon.

Dan
trailbuster30 is offline  
 
post #4 of 4 Old 01-24-2011, 08:04 PM Thread Starter
Stromthusiast!
 
Join Date: Apr 2008
Location: L.A.of,Colorado
Posts: 900
Dan, I appreciate the offer, thanks. I have it fixed for now and working. I believe I over loaded it, and thus the failure. So my fault. Thanks for standing behind your products. If I have a further issue with it, I'll let you know. Norm.
oldmanb777 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome