Wee would'nt rev out - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
V-Strom Modifications and Performance The brag page, good and bad.

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 10-05-2010, 03:48 PM Thread Starter
Stromthusiast!
 
rcacs's Avatar
 
Join Date: Sep 2005
Location: Morden, Manitoba, Canada
Posts: 2,557
Send a message via MSN to rcacs
Wee would'nt rev out

Noticed for the last lil while that my Wee wouldnt want to rev out, around 9K it was pretty enemic, and going to WOT resulted in actually slowing down some.

Did all the usual checks: TPS was good (middle and moved to upper at 1700); TBS (was only out by 1"); STV was bang on and I ran 2 tanks of fuel using some SeaFoam.

Decided that I would give the fuel filter mod a shot (has never been changed) found at:

External Fuel Filter modification

(thanks to the poster over at VSI)

I noted that there was actually only a bit of crud in the low pressure filter, so I was starting to think that maybe a partially plugged high pressure filter wasnt going to be the problem.

The Mod is actually very easy to do, just be sure to use proper fuel injection rubber hose (5/16") and clamps. I didnt bother trying to find a slightly smaller filter (would be much nicer though), and it is a pretty tight fit. If you look around for a smaller one, just be sure it is for fuel injection as the media is much smaller (around 10 microns I believe).

Pay special heed to the cutting off of the fuel line ends, so you dont wreck the small green o-rings. Placing a small amount of lube on the ends and just inside the hose helps with the install.

Once back together, you will note that the pump runs maybe a second or two longer to prime, but other than that there are no issues.

So, a test run proved that the filter was indeed restricted. She revs out nicely now, no bog.

All in all a pretty easy task, took me about 90 minutes start to finish and much much cheaper than getting a Zook filter (272.00 US from BikeBandit) and easily replaceable afterwards. The filter was from NAPA along with the hose and the clamps, total cost was right around 30 clams Cdn.

Cheers!

K5Wee in Kanada (285,500 KM and still going strong)
IF YOU WON'T STAND BEHIND OUR TROOPS.....FEEL FREE TO STAND IN FRONT OF THEM
[IMG]http://i1181.photobucket.com/albums/x438/rcacs/maps/VisitedProvincesMap.jpg[/IMG][IMG]http://i1181.photobucket.com/albums/x438/rcacs/maps/american.jpg[/IMG]

Last edited by rcacs; 10-05-2010 at 03:57 PM.
rcacs is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 10-05-2010, 09:38 PM
Stromthusiast!
 
maggot's Avatar
 
Join Date: Sep 2008
Location: Victoria BC Canada
Posts: 962
Well done, thanks for sharing.

Ken

2007 DL650 Gray
maggot is offline  
post #3 of 3 Old 10-07-2010, 07:43 PM Thread Starter
Stromthusiast!
 
rcacs's Avatar
 
Join Date: Sep 2005
Location: Morden, Manitoba, Canada
Posts: 2,557
Send a message via MSN to rcacs
After logging about 800km I can say that she definatly pulls harder from 6K up. I really hadnt noticed the loss as it was probably somewhat gradual.

An added bonus!

Cheers!

K5Wee in Kanada (285,500 KM and still going strong)
IF YOU WON'T STAND BEHIND OUR TROOPS.....FEEL FREE TO STAND IN FRONT OF THEM
[IMG]http://i1181.photobucket.com/albums/x438/rcacs/maps/VisitedProvincesMap.jpg[/IMG][IMG]http://i1181.photobucket.com/albums/x438/rcacs/maps/american.jpg[/IMG]
rcacs is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome