Admore Lighting Givi V35 Install - Help! - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
V-Strom Modifications and Performance The brag page, good and bad.

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 05-24-2010, 11:58 PM Thread Starter
Stromthusiast!
 
Join Date: Feb 2008
Location: Reno NV
Posts: 53
Admore Lighting Givi V35 Install - Help!

I installed the Admore LED kit in my Givi V35 bags on my ABS Wee this weekend. I drilled the connector hole with the bags off the bike, and when I installed the racks and went to put the right side bag on, I found the exhaust heat shield is interfering with the connector. I don't think I have enough cable to run the connector far enough down that it won't hit the heat shield. Admore says lots of V-Strom owners have used these, so it sounds like it must be operator error. Can anyone who has this kit give me some guidance, with some photos if possible?

Thanks in advance.
swingle12 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 05-25-2010, 09:09 AM
Stromthusiast!
 
LesHeight's Avatar
 
Join Date: Oct 2009
Location: Goldenrod, Florida
Posts: 108
Garage
Send a message via MSN to LesHeight
I had the same problem and had to re-drill the right side bag to position the connector a bit higher. You are right that going low enough to clear the muffler will run you out of wire.

If you email Admore they will send you a set of plugs that will fill the first hole perfectly (see the second picture).

Good luck,
Attached Images
File Type: jpg admore01.jpg (97.6 KB, 39 views)
File Type: jpg admore02.jpg (91.1 KB, 46 views)

LesHeight
2009 DL650 127k and counting
2015 DL650XT

Time you enjoy wasting was not wasted.
- John Lennon
LesHeight is offline  
post #3 of 3 Old 05-26-2010, 01:46 AM Thread Starter
Stromthusiast!
 
Join Date: Feb 2008
Location: Reno NV
Posts: 53
Thanks! That's exactly what I needed. I guess I should have done the re-assembly before I drilled. Looks like I'll be needing one of those plugs! It's a nice kit, but I do wish they'd included enough cable to route it below the exhaust.
swingle12 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome