Universal Vista Cruise - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
V-Strom Modifications and Performance The brag page, good and bad.

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 07-03-2008, 09:50 PM Thread Starter
Stromthusiast!
 
meanmotorscooter's Avatar
 
Join Date: Jul 2007
Location: NJ
Posts: 213
Universal Vista Cruise

I tried installing an NEP CC-4 and let me tell you it was a total waste of my time. The thing didn't work. Tonight I installed the Vista Cruise Universal for 7/8" bars. For about $10 more than the CC-4 I can't understand why anyone would pick the CC-4 over this. This thing just works. The install was easy and I didn't have to modify anything. The whole thing seems solid and easy to operate once installed. The NEP CC-4 is a piece of garbage compared to this. Now I know why the manufacture doesn't list the NEP as compatible for the Strom. Do yourself a favor if you're considering a throttle lock. Just order the MCUVOO Universal Vista Cruise for 7/8" bars
meanmotorscooter is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 07-04-2008, 02:55 PM
Stromthusiast!
 
2tall's Avatar
 
Join Date: Feb 2008
Location: Mississauga, Ontario, Canada
Posts: 815
Does it clamp around the throttle grip, or between the grip and the throttle housing? Do you have a picture? Can't really tell from the Casport picture. Do you have heated grips? I have the OEM heated grips, and not sure if it will work

Thanks in advance.
2tall is offline  
post #3 of 5 Old 07-04-2008, 03:02 PM
Stromthusiast!
 
rcacs's Avatar
 
Join Date: Sep 2005
Location: Morden, Manitoba, Canada
Posts: 2,557
Send a message via MSN to rcacs
You dont say what year ur Strom is, but I have a NEP on my Wee, works great, very minor modification to use it. I actually used a NEP CC 2.

I have the suzuki factory heated grips and factory hand guards.


I dont like the universal one as it takes up too much space on the grip.


But, whatever floats ur boat....

Cheers!

K5Wee in Kanada (285,500 KM and still going strong)
IF YOU WON'T STAND BEHIND OUR TROOPS.....FEEL FREE TO STAND IN FRONT OF THEM
[IMG]http://i1181.photobucket.com/albums/x438/rcacs/maps/VisitedProvincesMap.jpg[/IMG][IMG]http://i1181.photobucket.com/albums/x438/rcacs/maps/american.jpg[/IMG]
rcacs is offline  
 
post #4 of 5 Old 07-04-2008, 03:21 PM
Stromthusiast!
 
2tall's Avatar
 
Join Date: Feb 2008
Location: Mississauga, Ontario, Canada
Posts: 815
Mine is an '06 DL1000. Haven't seen a 650 with heated grips, so not sure if they are the same. Thanks though.

John
johnvstrom at yahoo.ca.............. V-Stromming since '03
'06 DL1000 Grey
'03 DRZ400$ sold, down to one bike
2tall is offline  
post #5 of 5 Old 07-07-2008, 11:07 PM Thread Starter
Stromthusiast!
 
meanmotorscooter's Avatar
 
Join Date: Jul 2007
Location: NJ
Posts: 213
Quote:
Originally Posted by 2tall View Post
Does it clamp around the throttle grip, or between the grip and the throttle housing? Do you have a picture? Can't really tell from the Casport picture. Do you have heated grips? I have the OEM heated grips, and not sure if it will work

Thanks in advance.
It goes around the grip, not between anything. I don't have heated grips but depending on how big the wire is, that might present a problem.
meanmotorscooter is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome