Need Some Help - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
V-Strom Modifications and Performance The brag page, good and bad.

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 08-20-2005, 03:03 AM
PlanoStrom
Guest
 
Posts: n/a
Need Some Help

Bought the grip puppies and so far they work great. My problem. I took the bar ends off and now I cannot get them back on. The whole unit including the end screw just slides around in the handle bars. I tighten the screw, placed my guards back on, but when I wiggle the bar ends to make sure they were tight I could litterly pull the whole unit out with two fingers. Went to the dealer and of course they were happy to fix it at $60.00 per hr. I see where others have lost the inside screw but this is not my problem. What am I doing wrong? Help
Sponsored Links
Advertisement
 
post #2 of 3 Old 08-20-2005, 04:56 PM
2003strom
Guest
 
Posts: n/a
When tightening the center bolt/screw, try to keep some outward tension on the bar end weight. You could also try to tighten up the nut on the bolt until you can barely slide it into the handlebars and then tighten it up. Also, you could wipe everything down with rubbing alcohol (makes everything tacky) and try to tighten it up.

Dennis
post #3 of 3 Old 08-20-2005, 06:43 PM
marndo
Guest
 
Posts: n/a
Yep, sounds like the rubber bushing is spinning, you just need to keep some tension on it.
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome