Takai COP issues - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
V-Strom Modifications and Performance The brag page, good and bad.

 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 05-22-2014, 02:29 AM Thread Starter
Stromthusiast!
 
Join Date: Aug 2011
Location: Rural north/central Louisiana
Posts: 944
Takai COP issues

Takai makes hi-output coil-over-plug units for the motoring public. I invested major bank when I bought a pair of their coils for my '06 Wee. When I tried to connect these coils to my wiring, I discovered that Takai didn't supply the correct sized connectors on for the positive side of the stock wiring. Suzuki was smart and sized these connectors so that it would be impossible to connect the leads in reverse polarity by utilizing two different sized connectors. The positive lead is smaller so that you can't possibly install the negative lead here because it won't fit. I am now going back and forth with Marc at Takai to correct this issue. To Takai's credit, Marc is making an effort to correct this issue on good faith. I have supplied photos along with the dimensions of the stock connectors as Marc's requested. FWIW.

'92 Honda Z50R
'94 Kawasaki KLX250 modded to 340cc's
'00 Yamaha YZ426F
'94 Yamaha 125 scooter
'05 Vespa E4 scooter
'68 Vespa VBB scooter (restored)
'06 Wee
'03 Honda S2000 roadster
Boit4852 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 05-23-2014, 04:07 AM Thread Starter
Stromthusiast!
 
Join Date: Aug 2011
Location: Rural north/central Louisiana
Posts: 944
Marc sent me an email today wanting me to remove the wire harnesses, send them to him, and he will send me the correct wire harnesses. I had explained that I had cut the sheath off of the offending connectors, cut the male connectors down with a Dremel and made them fit. I refuse to now go thru the hassle of removing these coil wires, sending them to Takai, wait for who knows how long, and then reinstall them. I'd be without my bike for 2 weeks. I told Marc. "No. That is not acceptable'. Suppose I did as he requested and Takai still sends me the incorrect harness. I'd be without my bike for more time. At least at this time, what I did works and I can ride. GRRRR...

'92 Honda Z50R
'94 Kawasaki KLX250 modded to 340cc's
'00 Yamaha YZ426F
'94 Yamaha 125 scooter
'05 Vespa E4 scooter
'68 Vespa VBB scooter (restored)
'06 Wee
'03 Honda S2000 roadster

Last edited by Boit4852; 05-23-2014 at 04:09 AM.
Boit4852 is offline  
post #3 of 7 Old 05-28-2014, 01:49 PM
Stromthusiast!
 
bwringer's Avatar
 
Join Date: Oct 2009
Location: Indy
Posts: 3,198
Why?

I don't recall ever seeing a problem with the stock coil and plug wire setup.

What's the point of going to the Coil-Over-Plug system?

I mean, I know why many cars and motorcycles are built this way. But what made you decide it's worth the effort to switch over a system in a V-Strom that works perfectly fine?


Also, it doesn't really sound like you're getting bad service. When you're dealing with products like this, or unusual or custom applications, sometimes you're the first or only customer with a particular model bike, so you have to provide some information to get things working correctly.

2002 Suzuki DL1000 V-Strom, Dark Metallic Space Blue
1983 Suzuki GS850G, Cosmic Blue
2005 KLR685, Aztec Red - Turd II.2, the ReReTurdening
bwringer is offline  
 
post #4 of 7 Old 05-29-2014, 02:36 AM Thread Starter
Stromthusiast!
 
Join Date: Aug 2011
Location: Rural north/central Louisiana
Posts: 944
Quote:
Originally Posted by bwringer View Post
I don't recall ever seeing a problem with the stock coil and plug wire setup.

What's the point of going to the Coil-Over-Plug system?

I mean, I know why many cars and motorcycles are built this way. But what made you decide it's worth the effort to switch over a system in a V-Strom that works perfectly fine?


Also, it doesn't really sound like you're getting bad service. When you're dealing with products like this, or unusual or custom applications, sometimes you're the first or only customer with a particular model bike, so you have to provide some information to get things working correctly.
I guess I am a performance geek. I read great reviews about COP from takai and since I enjoy tinkering, I decided to bank on it. COP systems are used now to achieve the greatest combustion chamber efficiency available. I enjoy making improvements on my Wee. At any rate, the latest developments are that Takai refuses to send me the correct wires(cables) unless I send them back to them so that they can install the correct connectors and send them back to me AT MY EXPENSE. I find this insulting as I spent major bank on their product and they provided a product that doesn't fit. Yes, I used my shade tree ingenuity to fix the positive side connector to get it working but it is not up to my standards . All I ask is for takai to send me the CORRECT wiring harness(about 10 inches long) so I can change it out and they refuse. I'll send them the flawed one back but only once I get the new ones and they fit. Am I being unreasonable? I'll have to take another 2 weeks downtime if I follow their directions. I've already spent nearly 3 hours of carefully modifying these COP's to fit and be properly insulted. What really got my goat is to have Marc be sarcastic about how the "engineers" are confident that they supplied the correct connectors. When I sent photos and caliper measurements showing that the positive side connectors were the wrong size, all I got was "send us the cables back....". Never had the decency to admit their mistake. Hey, mistakes happen, but own up and make it right. Is that too much to ask?

'92 Honda Z50R
'94 Kawasaki KLX250 modded to 340cc's
'00 Yamaha YZ426F
'94 Yamaha 125 scooter
'05 Vespa E4 scooter
'68 Vespa VBB scooter (restored)
'06 Wee
'03 Honda S2000 roadster
Boit4852 is offline  
post #5 of 7 Old 05-29-2014, 02:49 AM Thread Starter
Stromthusiast!
 
Join Date: Aug 2011
Location: Rural north/central Louisiana
Posts: 944
To expand on above, I bought a Factory Pro velocity stack kit from Blair at SV Racing Parts who is a vendor here. Blair and I ordered the stack kit for both of us at the same time and the kit was delayed for a few months due to availability. Once I received mine, I found that the stack adapters were too small and didn't fit. I immediately contacted Blair who stated that his tuner had no problem installing the adapters in an SV650 airbox.. From there, I thought I was an incompetent owner who didn't know what the heck I was doing. Yesterday, Blair emailed me to state that the adapters didn't fit his Wee either although they fit the SV and that he had contacted Factory Pro about the fitment issue and wanted to know where I was with Factory Pro. I had just received the replacement adapters from FP that were labeled to fit a GSXR 600. I measured the diameter of the sealing groove and it appears to be correct. I won't know until I try to install them. My point here is that FP is trying hard to correct this issue and I respect that. Mistakes happen. How a business deals with correcting those mistakes means a ton to me. Marc at takai is a poor business rep in my opinion. Factory Pro will learn from this that the SV and DL models don't have the exact same airbox intake opening diameters. Mostly likely what happened here was that assumptions were made. The SV and DL endinges are nearly identical but with tuning differences. Someone was lazy and assumed....same engine...same everything. I assume.

'92 Honda Z50R
'94 Kawasaki KLX250 modded to 340cc's
'00 Yamaha YZ426F
'94 Yamaha 125 scooter
'05 Vespa E4 scooter
'68 Vespa VBB scooter (restored)
'06 Wee
'03 Honda S2000 roadster

Last edited by Boit4852; 05-29-2014 at 03:01 AM.
Boit4852 is offline  
post #6 of 7 Old 05-29-2014, 02:53 AM Thread Starter
Stromthusiast!
 
Join Date: Aug 2011
Location: Rural north/central Louisiana
Posts: 944
Quote:
Originally Posted by bwringer View Post
I don't recall ever seeing a problem with the stock coil and plug wire setup.

What's the point of going to the Coil-Over-Plug system?

I mean, I know why many cars and motorcycles are built this way. But what made you decide it's worth the effort to switch over a system in a V-Strom that works perfectly fine?


Also, it doesn't really sound like you're getting bad service. When you're dealing with products like this, or unusual or custom applications, sometimes you're the first or only customer with a particular model bike, so you have to provide some information to get things working correctly.

I disagree with the bad service comment. I paid premium price for a product that was advertised as 'plug'n play' which didn't happen. Plugs didn't fit. Are you saying that I should pay for the product, then pay further to fix their mistakes?

'92 Honda Z50R
'94 Kawasaki KLX250 modded to 340cc's
'00 Yamaha YZ426F
'94 Yamaha 125 scooter
'05 Vespa E4 scooter
'68 Vespa VBB scooter (restored)
'06 Wee
'03 Honda S2000 roadster
Boit4852 is offline  
post #7 of 7 Old 05-30-2014, 03:08 AM Thread Starter
Stromthusiast!
 
Join Date: Aug 2011
Location: Rural north/central Louisiana
Posts: 944
Quote:
Originally Posted by bwringer View Post
I don't recall ever seeing a problem with the stock coil and plug wire setup.

What's the point of going to the Coil-Over-Plug system?

I mean, I know why many cars and motorcycles are built this way. But what made you decide it's worth the effort to switch over a system in a V-Strom that works perfectly fine?


Also, it doesn't really sound like you're getting bad service. When you're dealing with products like this, or unusual or custom applications, sometimes you're the first or only customer with a particular model bike, so you have to provide some information to get things working correctly.

What has finally happened is that takai refuses to send me the correct wire/connector sets for the 2 coils. I measured the connectors with a digital caliper and included that info along with clear pic of the stock coil connectors that show clearly the size difference. I received an email yesterday stating to never bother them again and they are NOT going to send me the correct wire sets.

'92 Honda Z50R
'94 Kawasaki KLX250 modded to 340cc's
'00 Yamaha YZ426F
'94 Yamaha 125 scooter
'05 Vespa E4 scooter
'68 Vespa VBB scooter (restored)
'06 Wee
'03 Honda S2000 roadster
Boit4852 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome