Why did my Stebel quit working? - Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums
V-Strom Modifications and Performance The brag page, good and bad.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 Old 01-11-2008, 06:52 PM Thread Starter
Stromthusiast!
 
Shredder's Avatar
 
Join Date: Oct 2007
Location: Concord, NC
Posts: 44
Why did my Stebel quit working?

It's only a few weeks old, never been in the rain. Mounted on the extra motor bolt hole with rubber dampers. Everything is connected, and the relay clicks when I hit the button. I've only hit it maybe 5 times, and it has about 50 miles on it. Any ideas?
Shredder is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 01-12-2008, 10:06 PM
Stromthusiast!
 
Join Date: Apr 2007
Location: Northern VA
Posts: 340
Have you put a volt meter on the power supply wires at the horn - to be sure power it is getting power to the horn?

Chuck

05 DL-1000 - A farkling project in the making....

"A free people ought not only to be armed and disciplined, but they should have sufficient arms and ammunition to maintain a status of independence from any who might attempt to abuse them, which would include their own government. George Washington
cbjr0256 is offline  
post #3 of 11 Old 01-13-2008, 04:38 AM
Stromtrooper.com Sponsor
 
Jim Davis's Avatar
 
Join Date: Nov 2007
Location: Japan
Posts: 504
The relay that comes with the Stebel horn is very poor. I've seen photos of some totally corroded inside even when new.

I would suggest getting a good quality SEALED relay.

Jim Davis, Owner, Eastern Beaver Company:
http://easternbeaver.com/ - Motorcycle Electrics: 2007 DL1000 with 16/43 gearing, Superbrace, Tokico 4 Pot fronts, BackoffXP, H4 Dual Relay Kit, PC-8 Fusepanel, 2 Powerlet Sockets, Suzuki Centerstand - 1988 Africa Twin 650, 1990 VFR 750.
Jim Davis is offline  
 
post #4 of 11 Old 01-14-2008, 02:39 PM Thread Starter
Stromthusiast!
 
Shredder's Avatar
 
Join Date: Oct 2007
Location: Concord, NC
Posts: 44
Quote:
Originally Posted by Jim Davis View Post
The relay that comes with the Stebel horn is very poor. I've seen photos of some totally corroded inside even when new.

I would suggest getting a good quality SEALED relay.
Turns out it was the relay. I got another one at Advance Auto, can you point me to one of these sealed ones?
Shredder is offline  
post #5 of 11 Old 01-16-2008, 07:09 AM
Stromthusiast!
 
longgreensilverado's Avatar
 
Join Date: Sep 2007
Location: agawam, ma
Posts: 537
my stebel quit working also, due to a blown fuse. I wired it right with the relay and made a water proof jacket for the relay. i checked all connections and wiring and can only guess i used the wrong fuse. i was using a 10amp and replaced with a 25.
longgreensilverado is offline  
post #6 of 11 Old 01-16-2008, 09:06 AM Thread Starter
Stromthusiast!
 
Shredder's Avatar
 
Join Date: Oct 2007
Location: Concord, NC
Posts: 44
The wiring kit I got with mine had a 30 fuse in it.
Where did you put your relay? Mine's under the seat in the little tool compartment, so I know it's not subject to the weather.
Shredder is offline  
post #7 of 11 Old 01-16-2008, 09:22 AM
Stromthusiast!
 
longgreensilverado's Avatar
 
Join Date: Sep 2007
Location: agawam, ma
Posts: 537
my relay is tucked up under the fairing high up in the left corner and is water tight. maybe i was right the first time when i installed with a 30 amp fuse. i went with a 10 because i thought 30 might be too high.
longgreensilverado is offline  
post #8 of 11 Old 01-16-2008, 09:33 AM
FORUM GODFATHER.....R.I.P. PAT
 
greywolf's Avatar
 
Join Date: Jan 2006
Location: Evanston IL USA
Posts: 38,049
Garage
A 20 amp fuse with 14ga wire overkill or 16ga wire being okay is the way to go. I've read reports of the current draw being in the teens. If a 30amp fuse is used, 10ga wire is needed. The fuse needs to be sized to protect the wire from overheating.

Pat- 2007 DL650A was ridden to all 48 contiguous states. I didn't quite make it to 17,000 miles on the 2012 DL650A.
Nicknames I use to lessen typing, Vee = 2002-2012 DL1000s. Vee2=2014-2016 DL1000s. Wee = 2004-2011 DL650s. Glee = 2012-2016 DL650s
See https://www.stromtrooper.com/general-...nicknames.html

Please vote in the poll on what Strom(s) you have at https://www.stromtrooper.com/informat...-you-have.html
greywolf is offline  
post #9 of 11 Old 01-16-2008, 09:36 AM
FORUM GODFATHER.....R.I.P. PAT
 
greywolf's Avatar
 
Join Date: Jan 2006
Location: Evanston IL USA
Posts: 38,049
Garage
Quote:
Originally Posted by Shredder View Post
Turns out it was the relay. I got another one at Advance Auto, can you point me to one of these sealed ones?
Eastern Beaver is a good place. It's Jim's company. See his sig.

Pat- 2007 DL650A was ridden to all 48 contiguous states. I didn't quite make it to 17,000 miles on the 2012 DL650A.
Nicknames I use to lessen typing, Vee = 2002-2012 DL1000s. Vee2=2014-2016 DL1000s. Wee = 2004-2011 DL650s. Glee = 2012-2016 DL650s
See https://www.stromtrooper.com/general-...nicknames.html

Please vote in the poll on what Strom(s) you have at https://www.stromtrooper.com/informat...-you-have.html
greywolf is offline  
post #10 of 11 Old 01-17-2008, 11:52 AM Thread Starter
Stromthusiast!
 
Shredder's Avatar
 
Join Date: Oct 2007
Location: Concord, NC
Posts: 44
Quote:
Originally Posted by Jim Davis View Post
The relay that comes with the Stebel horn is very poor. I've seen photos of some totally corroded inside even when new.

I would suggest getting a good quality SEALED relay.
Hey Jim, do you sell just the relay, not the whole kit? If you could send me a link via e-mail or PM I would appreciate it.
Rob
[email protected]
Shredder is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Stromtrooper Forum : Suzuki V-Strom Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome