StromTrooper banner

1 - 5 of 5 Posts

·
Registered
Joined
·
255 Posts
Discussion Starter #1
Just checking to see if others have experienced... I have a Garmin Zumo 550 that I have been using since new, about 4 years. Lately it seems that the touch screen interface is failing. In bright sunlight there is an opaque pattern of dots that appear like a mask over the screen, and when I touch a selected command it often will pick an adjacent field, or nothing at all. Any option that allows for using the "+" or "-" hard keys works great, so it does appear limited to the touch-screen interface.

Looking for ideas as it is becoming less and less useful as this issue seems to get progressively worse. I hate to trash it, but at some point... :headbang:

Any thoughts appreciated.
 

·
FORUM GODFATHER.....R.I.P. PAT
Joined
·
38,048 Posts
Try taking out the battery for a minute and see if that helps. If not, call Garmin. I've been very happy with their customer service.
 

·
Registered
Joined
·
255 Posts
Discussion Starter #3
Try taking out the battery for a minute and see if that helps. If not, call Garmin. I've been very happy with their customer service.
Great advice Pat, thanks! No dice on the battery pull, but I called Garmin customer service, reached a live person, in the US, and despite the unit being over 4 years old he was happy to help.

He walked me through a screen calibration and then a master restart, tested and HOO-RAY, all is well! :hurray:

I will admit to having something of a "duh" moment when I saw the suggestion to call support, mostly because of the age of the unit. As an aside for those that might have similar issues in the future, if this fix had not worked, in the worst case scenario Garmin would do a repair/refurb on the unit for $150 plus shipping.

Again thanks.
 

·
Premium Member
Joined
·
8,025 Posts
1 - 5 of 5 Posts
Top