Strom Trooper banner

1 - 17 of 17 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Had an interesting day yesterday. First up was a new headlight bulb at the shop all good. Then a 60 min ride and after a refuel it would not start. Turns over but no fuel pump prime to be heard. No gear indicator on dash and the dreaded “chec”. Got a tow back to the shop. And of course nothing to be seen starts normally when I get there. Sent on my way, and then 2 km on the way home it stalls at the lights and same issue. They collect me and now it’s in the shop. 2017 DL 1000. I don’t believe in coincidences is there anything that could be dislodged or loose behind the dash from the lightbulb replacement that could be the cause. It was the low beam bulb. They must have had battery disconnected as the clock was off, but they have said they checked terminals etc...Any help from the brains trust appreciated.
 

·
Registered
Joined
·
972 Posts
I have come to the point where anytime something goofy like this happens I suspect the clutch safety switch. The relationship between this switch and the ECU is a known issue with the GSXRs and it is a fussy little switch. Sometimes the switch just fails, internally. It can get misaligned from handling like using tie-down straps. It is simple for your shop to eliminate it as a suspect but I've learned that not all shops think about it on the V Strom even though they check on the GSXR. It seems that both bikes have ECUs which share some DNA.

In my case my bike went into "limp mode" in the middle of a ride for no known reason. I had the code light come on and the instrument info disappear. If I pulled over and stopped for a while it would be okay for a few miles with no code showing and then fail again. After a couple of days and tank on / tank off / tank on etc. I took it into the shop. They tested this and that. Then I read a somewhat unrelated post from Greywolf in which he asked the OP if the bike would turn over without pulling the clutch lever.

Fast forward, I now have a spare clutch safety switch taped to the bottom of my seat.
Be sure to let us know ...
 

·
Registered
Joined
·
972 Posts
No CHEC message associated with the clutch safety switch.
True. And as of at least this past spring, no Suzuki service advisory to the dealers. The dealer I use confirmed it via phone with Suzuki HQ.
 

·
Registered
Joined
·
3,043 Posts
It is none of the usual suspects as the motor turns over. (if that is still the case)

No check with a clutch switch issue and the motor would not turn over.

A check and a hold out for the stand is not evident if the bike is in neutral.

A check for the kill switch will stop the prime but will also stop the motor turning over.

The 10amp ignition fuse will show a check but the motor will not turn over.

The 30amp fuse will leave everything dead.


What is displayed on the dash where it would display what gear you are in ?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #7
Thank you everyone for your comments. The shop phoned today. Faulty wiring loom. They could get it started by wiggling the wiring "at the back". They could make it stall by wiggling as well. New loom on order ex. Japan, 2 weeks. Under warranty.
 

·
Registered
Joined
·
2,896 Posts
Thank you everyone for your comments. The shop phoned today. Faulty wiring loom. They could get it started by wiggling the wiring "at the back". They could make it stall by wiggling as well. New loom on order ex. Japan, 2 weeks. Under warranty.
Glad to hear they got it sorted! Sounds expensive if it hadn't been under warranty :)

Just wanted to add when they replaced the bulb it is highly unlikely they unhooked the battery. When you take the dash off there is a plug in for the wiring for the dash and one for the 12V socket. Both of those are unhooked to remove the dash and it resets the clock, distance to empty, etc.
 

·
Registered
Joined
·
431 Posts
If would be helpful for others if you could share a picture of the faulty area of the damaged wiring. There have been wire loom issues noted on past models.

Sent from my SM-G930V using Tapatalk
 

·
Registered
Joined
·
3 Posts
Discussion Starter #17
Thanks everyone for your replies. The bike has 17 000 KM on it, so not much really. I will try and get some photos of the loom that comes out. Cheers
 
1 - 17 of 17 Posts
Top