StromTrooper banner

1 - 6 of 6 Posts

·
Registered
Joined
·
643 Posts
Discussion Starter #1
My ABS light began coming on intermittently a few weeks ago, and not it's constantly on. I know this means there's a problem with the ABS system and I'm hoping to do some trouble-shooting this weekend.

I'm hoping for an easy fix like a blown fuse -- can anyone advise where I can find my ABS system fuse?
 

·
Registered
Joined
·
20 Posts
There are two fuses for the ABS system near the battery. Both have covers with "ABS" on them - One is 15A and one is 25A, I think. I don't believe any of the fuses in the actual fuse box relate to the ABS.
 

·
Registered
Joined
·
3,719 Posts
Am intermittent problem isn't a fuse more like a loose connection.

Check the sensors at the hub rings. Take them off and clean the ends. Check the wires themselves for nicks or breaks. Follow the wires back to where they plug in to the harness. Check the connections on the ABS computer.
 

·
Registered
Joined
·
8 Posts
Mine comes on on my 2012 650 only in the rain. I have had a suzuki mechanic look and it is not producing a code. I suspect water is causing a poor electrical connection somewhere and causing the light. My signal lights also occasionally not work in the rain.

The headlights stopped during last summer after a rainy ride and was forced by chasing wiring harnesses and cleaning corrosion out of one of them.

I suspect the same issue from the signal lights and abs light

Sent from my SM-A520W using Tapatalk
 
1 - 6 of 6 Posts
Top