StromTrooper banner

1 - 6 of 6 Posts

·
Registered
Joined
·
168 Posts
Discussion Starter #1
I was cleaning the dirt off my bike yesterday and, after drying it off, it would no longer start up. I turn the key and the pump primes and everything seems ready. There is a solid red light and no error message. The starter does not engage. I did notice a slight tear on the outee cover of the kickstamd switch wire, but I haven't had any trouble with it previously.

My bike is an 08 with 8200 miles. Any ideas or things to check?
 

·
Registered
Joined
·
1,571 Posts
Check; Red cut out switch in run position? Clutch safety switch wiring connector (comes out under clutch lever pivot point) check firmly connected? Since some damage is apparent on the side stand switch wiring it should be checked very carefully, electrically and mechanically. A previous poster had the same thing and had intermittent trouble starting.:var_52: Good luck and let us know how it turns out.
 

·
Registered
Joined
·
41 Posts
I was cleaning the dirt off my bike yesterday and, after drying it off, it would no longer start up. I turn the key and the pump primes and everything seems ready. There is a solid red light and no error message. The starter does not engage. I did notice a slight tear on the outee cover of the kickstamd switch wire, but I haven't had any trouble with it previously.

My bike is an 08 with 8200 miles. Any ideas or things to check?
Thats why I dont wash mine:rolleyes:
 

·
FORUM GODFATHER.....R.I.P. PAT
Joined
·
38,103 Posts
No CHEC at the clock position normally means a clutch switch wire came loose at the lever. It usually follows a washing or a drop. Kill switch and side stand switch problems throw a CHEC code.
 

·
Registered
Joined
·
168 Posts
Discussion Starter #6
It was the clutch trigger plug. At least I will know for next time. That's what I get for washing the bike. :D
 
1 - 6 of 6 Posts
Top