StromTrooper banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1,347 Posts
Discussion Starter · #1 ·
So, recently i've noticed that when coming to a stop, my exhaust seems to "catch-up" to me and for a few seconds i can smell the bike's exhaust. I never noticed it having a smell when starting up and after it idles for a few seconds the smell goes away.

TBS and TPS check have been performed within a few thousand miles. I was all set to have a custom dyno map done last week, but thought twice about it since i've no idea if it made sense to do a map if there were a physical (i.e., not computer setting) problem with the bike.

so the question is, are there physical problems other than FI settings that can cause a rich running problem?

p.s. 2007 1k, with ~15,000 miles. intake and exhaust are stock and FI settings (as far as I know) are stock. air filter is new.

tia
 

·
Registered
Joined
·
4 Posts
This is a great question. I purchased an 05 V 2 months ago and have slowly been going through the bike changing fluids, tweaking the power commander, so on... No matter how much I tweak the power commander I smell (what I think) is a rich condition when stopped. My bike, 05 with 12k miles, Powercommander, stock pipes with the the tips cut out, not sure about the secondarys. I know I need to do a TPS/TBS, but have not gotten around to pulling all of that plastic off again (I seem to scratch it every time I try to put it back together). My plan is to pull the plastic off soon and do the following:
1. New Air Filter
2. New Spark plugs
3. Check Secondary's (if there are any)
4. TBS / TPS Adjustment

Any thoughts?

BTW, I had a BMW r1200gs (07) previously and needed to sell it to free up some cash. So far I really like the Strom. Engine is strong, like the ride, has lots of power. Completely different bikes, but for 1/2 the cost, you cannot go wrong.
 

·
Registered
Joined
·
4 Posts
I replaced the plugs, air filter, and adjusted the throttle bodies on my bike and still had the rich smell in my exhaust when stopping. I ended up zeroing out all of the cells in my power commander setup and the smell stopped. I did notice that when I zero'd out the map there was an 8 in the 1250 range at 5% throttle. I am thinking that this may have had something to do with it. I also now feel the lean area (3500-4000rpms) that people have mentioned. I am now going to try some of the other maps mentioned in this forum. I know that Chef's maps appear to be the most popular, so my plan is to try these out.
 
1 - 3 of 3 Posts
Top