StromTrooper banner
1 - 8 of 8 Posts

·
Registered
Joined
·
2,297 Posts
Discussion Starter · #1 ·
I have a Stebel airhorn that intermittently fails to sound the high tone. The low tone alone is still plenty loud, but what puzzles me is that the high tone comes and goes. I did my best to see that the horn body and compressor were fitted tightly together. There is an intake hose attached, but the horn was in use for a year or two without the intake hose on another bike, so it's possible there's some grime in there.

Is this a known problem with a known fix?

Cheers -d
 

·
Registered
Joined
·
3,624 Posts
It's only a "known" problem in that Stebels are known to be hit or miss when it comes to quality. They all seem to sound a little different.

The one on my GS850G is one of the good ones -- instant thunderous racket when you push the button.

The Stebel nautilus on my Vee is pathetic -- it takes about a half second to make any noise, and it's sorta wheezy. Thus far I've been too lazy to switch it out.

If you gently take it apart and look around, you might find some dirt or something that explains the problem. Maybe a pebble that's rattling around and causing it to be intermittent.
 

·
Registered
Joined
·
780 Posts
The high tone on my Stebel refuses to operate if the ambient temp. is less than 60 degrees........:confused:
 

·
Registered
Joined
·
2,297 Posts
Discussion Starter · #4 ·
It's only a "known" problem in that Stebels are known to be hit or miss when it comes to quality.
The unreliability was the reason I switched to Fiamms. I might just go back.

The Stebel is not that much louder, if at all, and frankly, if it's not reliable, it might as well not be there at all.
 

·
Registered
Joined
·
3,906 Posts
.... and frankly, if it's not reliable, it might as well not be there at all.
Reliability should always be #1 when it comes to safety and self defense.

Although I've not used my oem horn for anything other than to toot Hi, or see ya later, it always works.
 

·
Registered
Joined
·
2,505 Posts
I have the same problem - high tone doesn't work any longer.
This is the second kit from PWD, after the first one had the same issues.
And the horn has an air intake cover and also a plastic tube. So the air should be clean.

Just poor build quality. :thumbdown:

Has anyone opened up a stebel horn? Maybe there is a procedure for cleaning the inside of the horn?
 

·
Registered
Joined
·
2,505 Posts
Air leak.....who knows where's.....?
From what I understand the problem is a reed which doesn't vibrate - it is jammed for some reason.
Airleaks should have shown a wheezing sound (of leaked air), but there is no such sound.

I suspect the reeds inside either got wet or dirty.
But what is the correct procedure to open up the airhorn and clean it? Is it doable?
 
1 - 8 of 8 Posts
Top