StromTrooper banner

1 - 20 of 63 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
on my way home from work friday my stator burned up. darn near burned the powdercoating off the left engine cover. just out of warranty and stator is backorderd indefinetly.
 

·
Premium Member
Joined
·
1,902 Posts
Sorry to hear of it. Were you running electrical accessories? Don't let it spoil your holiday. :beatnik:
 

·
Administrator
Joined
·
17,397 Posts
Make sure your oil level is ALWAYS at the full line!!!!!
 

·
Registered
Joined
·
31 Posts
Discussion Starter #5
this bike is basicly my car, i ride it every day and only have motorcycle parking at work. i got a dl650 for reliability not because i like it the best. i am a mechanic and i know anything can fail at any time, but burning up a stator in 1 year is a bit early. and the really bad part, not a single stator in the country and no idea when i can get 1 from japan. im much more concerned about down time than the money.
 

·
Registered
Joined
·
93 Posts
Bike Bandit shows they have a stator for a 2012 in stock on their website. That's where I got mine a year or so ago. Took less than a week to ship it to me.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #7
i see a stator for a 07-11 but nothing for a 2012. is it a oem or aftermarket part you are refering to, thanks,
 

·
Registered
Joined
·
93 Posts
I was looking at the oem 2012. Bike Bandit has their same part # for 2011 and 2012, but if you look up the Suzuki Part #'s you get 32101-17ZG10 for 2011 and 32101-17G11 for 2012. Next question is does anyone know if the stator is the same for the Wee and the Glee? A 1 digit difference in the part number might not necessarily mean the part is any different from the prior model.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #11
im not sure if an earlier stator will fit or not. its possable, i towed the bike to suzuki to have it checked out. i have been dealing with the same dealer for 25+ years, and am requesting some kind of help from suzuki. it's possable suzuki may good will warranty this. i year and 23k is a little soon for electrical problems.
 

·
Premium Member
Joined
·
1,929 Posts
Just out of curiosity Sacbandit at what level do you keep your oil? Just trying to determine if there's any connection with oil level and stator burnouts as some are claiming.
 

·
Registered
Joined
·
155 Posts
What about just having the stator rewound and wile your there raise the wattage output. Or is the failure totally damage the stator?

DRD
 

·
Registered
Joined
·
2,414 Posts
Check flebay for a used Gladius stator.

I got Gladius pistons for my 2012, they have different part numbers, but I swear they are the same pistons. Need an engineer to tell.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #15
the strange part is, I just returned from a 1,000 mile weekend trip. i ran about 80 mph on the freeway for the whole weekend. when i checked my oil the next day it was black as coal, this was strange because the oil was recently changed. so i changed the oil again and a couple days later the stator failed. i think the stator got hot because i was running so long on the freeway. not sure, hopefully this is not going to be a common glee problem.
 

·
Registered
Joined
·
240 Posts
stator issue...

I doubt the oil is the issue. I drove my 2012 from New York to California and back in mid August. At some points it was 120+f in California/Arizona....and putting along at 75.
Like all bike companies they sub out the parts and like anything else...you occasionally get a bad part. I think you did.
If you think this is a problem check out the comments at the BMW sites. My BMW GT had a defective shaft seal at 800 miles.
 

·
Registered
Joined
·
574 Posts
Mine went at 24,000 mi. Replaced with stock Suz and mosfet regulator. No problems yet at 36,000 mi. I've got an e-mail from a guy that does rewinds. Pretty fast turnaround time he says. He states he can tell where the problem is and upgrade it so it doesn't happen again. Let me know if you want to contact him.
 

·
Banned
Joined
·
1,049 Posts
overheated engine oil can fry a stator

overheated engine oil can fry a stator. detonation can cause extreme heat and overheat engine oil. to prevent detonation, use regular fuel with the highest AKI rating. that what i do. i'm still running original stock stator on DL1 with 110k showing on the clock. go figure.
 

·
FORUM GODFATHER.....R.I.P. PAT
Joined
·
38,103 Posts
overheated engine oil can fry a stator. detonation can cause extreme heat and overheat engine oil. to prevent detonation, use regular fuel with the highest AKI rating. that what i do. i'm still running original stock stator on DL1 with 110k showing on the clock. go figure.
That's total nonsense.

1. It's lack of oil contact over time rather than high oil temperature that allows stator overheating from power shunted to the stator by a shunt type R/R. That's why the failure always happens at the top.

2. The heat due to detonation is very localized and does not affect engine oil temperature which is kept down by the oil cooler, air over the engine and the water jacket.

3. Detonation is an extremely rare problem on V-Stroms, all of which are designed to run fine on 87AKI at sea level. Only extraneous forces such as carbon buildup cause pinging.

4. Another single bike example is Wera688's Vee going 172,800 miles on it's OEM stator using 87AKI fuel. http://www.stromtrooper.com/dl1000-...000-mile-k3-dl1000-comprehensive-writeup.html and now has over over 300,000 miles with one stator change in the middle of its life.
 

·
Registered
Joined
·
944 Posts
1. It's lack of oil contact over time rather than high oil temperature that allows stator overheating from power shunted to the stator by a shunt type R/R. That's why the failure always happens at the top.
Every time I read the "keep the oil level high to prevent failure" comment I want to ask; where's the data. The failure at the top was the info I was missing and seems to support the high oil level theory.

I always run my Vee at the top oil fill line. Almost 30K miles on the OEM, but I'm thinking I may be seeing some early failure signs. My voltmeter tells me that somedays the charge is fine and, on rare occasions, it is not. Ohm metering the stator shows no problem so it could be intermittent or it could be jest one of those things a bike does from time to time....

For now, I'm continuing to ride as I normally would which includes carrying a cell phone and a credit card. :fineprint:
 
1 - 20 of 63 Posts
Top