StromTrooper banner

1 - 20 of 23 Posts

·
Registered
Joined
·
1,670 Posts
I had a conversation with Rick a couple of days ago. I dont have the '17 DL650 service manual. But my '14 DL1000 service manual shows the speed sensor reading originating in the ABS wheel speed sensors, not a countershaft sensor. The speed sensor is not shown in the parts microfiche as it is on older DL650s, so from this I believe the ABS control unit supplies the vehicle speed data via the ABS wheel speed sensors.
The service manual diagnosis specifically mentions wheel speed sensors for speedo malfunctions.
 

·
Registered
Joined
·
3,939 Posts
Yes the 14' 1000 is from the "front" ABS sensor.

The speedo input is a pink wire on the right side, under & near the front of the tank.

I don't know if that helps.
 

·
Registered
Joined
·
536 Posts
Does this version of the DL650 have traction control? If so it likely uses the abs sensors to determine the speed same as the 2014+ DL1000

..Tom
It does. And I know from own experience that the front sprocket change on my ‘17 did not change the speedometer reading so it must use either the front or rear ABS sensor.
 

·
Vendor
Joined
·
5,423 Posts
Discussion Starter #10
The 2017+ DL650 does not have the same kind of speed sensor connection as the previous DL650 models. 12 O clock labs can guide you through the installation for your bike, but our happiness guarantee applies here.

The speed sensor connection for the other models depends on year of bike.
 

·
Registered
Joined
·
68 Posts
12 o'clock labs

I purchased the S1 from AdTech.
here's what the guys are 12 o'clock told me...

The 2017 650 v-strom does not have a speed sensor plug,
S1 model will fit these bikes... SDRD-S1 Suzuki V-Strom DL1000 (2002-2013) / SDRD-S1 Suzuki V-Strom DL650 (2004-2016)
On the 2017 DL650 model the ABS computer sends a speed signal directly to the gauge cluster through the wire harness, their is no in-line plug for the signal.
We still have a calibration solution for those bikes, it requires installing an in-line connector on the speed signal wire right before it enters into the gauge cluster, and using SpeedoDRD model U1.
We can send you the U1 harness for your SpeedoDRD, no need to buy a new speedoDRD, I just need to know if your have the Green Rectangle SpeedoDRD or the Black Square SpeedoDRD.
Attached is a diagram of how the install would be done, we have a generic demo video I can upload over the weekend and email to you by Monday, shows how the U1 would install.


Which means @richlandrick that you're selling the wrong parts on your site. :-(
 

Attachments

·
Vendor
Joined
·
5,423 Posts
Discussion Starter #12
Almost. With apology, I "sold" the wrong part on my site. Past tense. Once we found out out that Suzuki changed the wiring in 2017 I changed the website.

The part you have can be used. According to Brooks at 12 O'Clock labs the S1 can be used by removing the plug. That is the difference between the U (universal) and the S1. The S1 has a plug, the U has no plug and ends in bare wires. Feel free to call me and we will make sure you achieve installation nirvana.

Uh-oh, I just checked our website and the change did not show. Looks like the change was made to the code, but not published. My bad. I'll fix that right now.
 

·
Registered
Joined
·
68 Posts
I spoke too soon. This is messed up. It only took 20 mins. I'm a whizz at getting the dash off now. Just took it for a ride and the speedo doesn't work. I notice there are two brown wires on the diagram. I hope they're the same otherwise I've tapped in to the wrong one. I've tapped in to the one that goes to the cluster. No idea where the other brown one is. I need to pull it all apart again. grrrrrr.

I've emailed Brooks too.
 

·
Registered
Joined
·
68 Posts
OK, now it's fixed.
In the above diagram from 12o'clock you'll notice TWO brown wires. The thin one that goes in to the console is NOT the one you want. The first photo from me shows that I tapped in to that. It's the ABS sensor. Don't do that.

The one you want is the FAT brown wire that goes in to the front light cluster. Unfortunately, that means you need to take the whole nose cone off to get to it. After that, it's all straight forward. Of course, if you didn't want to take the nose off, it's also in the main harness connector on the left side of the bike. You could just run a wire from there.

My ride seems to require a -8% adjustment.
 

Attachments

·
Premium Member
Joined
·
510 Posts
The 2017+ DL650 does not have the same kind of speed sensor connection as the previous DL650 models. 12 O clock labs can guide you through the installation for your bike, but our happiness guarantee applies here.

The speed sensor connection for the other models depends on year of bike.
How come the 12:00 website doesn't show the 2017+ DL650?
 

·
Registered
Joined
·
3,939 Posts
It does. And I know from own experience that the front sprocket change on my ‘17 did not change the speedometer reading so it must use either the front or rear ABS sensor.
If you have a centre stand you can work out front or rear.

Spin both wheels and see which gives a output.

On the 2014 v2 it's the front, if you keep a wheel stand going long enough it will show up.
 
  • Like
Reactions: V-Tom

·
Premium Member
Joined
·
510 Posts
OK, now it's fixed.
In the above diagram from 12o'clock you'll notice TWO brown wires. The thin one that goes in to the console is NOT the one you want. The first photo from me shows that I tapped in to that. It's the ABS sensor. Don't do that.

The one you want is the FAT brown wire that goes in to the front light cluster. Unfortunately, that means you need to take the whole nose cone off to get to it. After that, it's all straight forward. Of course, if you didn't want to take the nose off, it's also in the main harness connector on the left side of the bike. You could just run a wire from there.

My ride seems to require a -8% adjustment.
So you're saying the diagram from 12:00 is wrong? I assume you're saying that the correct brown wire is the wire on the diagram that is two wires to the left (improper) wire with the red X on it?
 
1 - 20 of 23 Posts
Top