StromTrooper banner
221 - 240 of 251 Posts

·
Registered
Joined
·
5,649 Posts
In the last bike was bulb lamp and in the new wee 2018 is led.
I think you will find that the LED is your problem.

Do a search someone must have found a way to overcome it.

Possibly just adding a globe inline with the LED or a relay.
 

·
Premium Member
Joined
·
4,006 Posts
I answered you on the other thread, yes you need a brake relay.

As far as the momentary switch that is how I wired in both my Rostra's. I see no need for a big control box and if happen miss setting the speed I want, I just tap the brake and do it again.
 

·
Registered
Joined
·
17 Posts
I answered you on the other thread, yes you need a brake relay.

As far as the momentary switch that is how I wired in both my Rostra's. I see no need for a big control box and if happen miss setting the speed I want, I just tap the brake and do it again.
Hi Motor 7.
I agree with you about no need a big control box. I never used one in my 200.000Km.
About the brake relay, I put one using the diagram showed in my previous post but the rostra did not worked. I did a search and I will change the brake relay connections.
Before that I will try put the rostra in check mode using only my on/off/on momentary switch.
My best.
 

·
Registered
Joined
·
0 Posts
First off, thank you to everyone for their work, and for sharing it with the rest of us. I’m well on my way to having cruise on my ‘04 DL650. Does anyone see an issue with the purple wire being connected at the rear, rather than under the gas tank bracket? I have access to it, because I had a loose turn signal to tighten. Thanks in advance!
 

Attachments

·
Registered
Joined
·
17 Posts
Hi there.
I am back with the same problem in my rostra installation.
After add a break relay in the wiring diagram the rostra is not working.
So, I´d like ask to Wee members if somebody had installed rostra or audiovox electronic cruise control in the new Vstrom2017/2018 and could provide the wiring diagram and the 11 switches configuration of module.
Thanks a lot.
 

Attachments

·
Registered
Joined
·
29 Posts
Doing a lot of research on this topic. Coming from a ride that was equipped with an OEM "automotive" type cruise control, I miss this function.

There seems to be two choices. ROSTRA or MCCruise. I'm not trying to "penny pinch". I'm interested in a system that is safe and reliable.I freely admit I'm not convinced that I'm capable of doing the install on either system, but I'm willing to try.

Before I take the leap I'd like to speak to someone who has successfully gone through this.

I live in Phoenix, AZ. Fell free to PM me.

Thanks in advance...

Kimble

New 2019 DL650
 

·
Official Stromtrooper.com Sponsor
Joined
·
5,802 Posts
Kimble, the problem you are facing is the 2019 model. I done my 2012 with help from what others had posted. But the 2019 has some issues that are going to require figuring out. Without the bike in front of me, or others, there isn't much anyone can do to help.

I have helped a few others with the install on the earlier generation bikes. The number ONE biggest problem is owners trying to re-invent the wheel. Do the install EXACTLY how described in the posts from owners that have successfully done the work. If for instance the tail light being LED is the problem on a 2019 then that is one problem instead of many to figure out. There will be a correct wire to use, or a way to get around the problem. A factory service manual with wiring diagrams is a must for a project like this.

Get it working first....then re-invent the wheel. While not using the control switches might be cheaper, I cannot tell you how much more simple it seems to be to use the factory Rostra control switches!
 

·
Registered
Joined
·
770 Posts

Attachments

·
Registered
Joined
·
4 Posts
I just finished installing the Rostra on my 2009 Dl1000. I found these instructions to be spot-on and really appreciate this site. I didn't even have to adjust ANYTHING!

Two items I noticed....
*You hardly need any slack in the Cruise cable. Maybe 1/4 of sag max.

* The Vehicle Speed Sensor (VSS) pulse rate is 6k. It took a bit of searching to find this.

My settings: Gain on low, pulses to 6k, 4cyl low, square wave, manual tranny, clutch
Open circuit switch.

Dont be afraid if this install and Good Luck!
 

·
Registered
Joined
·
17 Posts
Has Anyone successfully installed Rostra on 17' & up V-strom 650 ?
Hi there Kelrich. I am trying install rostra cruise on the 2019 wee for more than 1 year, and no success.
I did the self diagnostic and it all ok, but rostra is not working, yet.
I put the traction control (TC) in off position and the same result, NO WORKING.
I used rostra in the Wee 1st and 2nd generations, and work very well.
I do not know what is happen with 3rd wee generation, since the difference is the TC.
I hope that some 3rd generation wee owner can help.
I attached the wiring diagram that I have been using
My best
 

Attachments

·
Registered
Joined
·
15 Posts
I've read through this thread to be familiar with the 3rd gen Rostra install but I've seen no cases of success, but corrections are in order. I just purchased a 2020 650A and intend to install a active cruise control. Here's some musings

Are any of the successful installs 650A's? I'm wondering out loud if the non working bikes have ABS and the VSS signal from the ABS wheel speed sensor is a problem. It appears the 2017+ ABS sensor gives 50 PPR (Pulses Per Revolution) which factors into a very high PPM (Pulses Per Mile) and it might be too much for the Rostra or does the 2017+ 650A VSS generate enough voltage for the Rostra to translate properly. Input?
With that said has anyone used the Rostra Speed Signal Generator 250-4165? I plan on this separate generator for VSS source if I do the Rostra. I hope this helps in trouble shooting.

And then there's the LED taillight to which the gurus have supplied a relay to work that out.

What I have:

I have a CCS-100 that I pulled off my 06 C10 before selling the bike but I'm not sure where to tap into the vacuum of the 650A. Input?

On my K7 I successfully used my right crash guard, SW Motech?, for a reserve vacuum canister and plan on using the Happy Trails right. either side would work, crash guard if I install the CCS-100. But I also have the vacuum cannister I used for the C!0 install so I'm covered all the way around.

I would also want to use the Rostra signal generator to make sure I have a good VSS.

And yes there is still need for the LED relay.


These are my thoughts and hope someone wishes to comment with positive thought. Thanks in advance.
 
221 - 240 of 251 Posts
Top