StromTrooper banner

1 - 4 of 4 Posts

·
Registered
Joined
·
810 Posts
Discussion Starter #1
After 85K miles and a recent stator replacement I thought it would be a good idea to also replace my voltage regulator/rectifier (R/R). It was the OEM shunt type but I opted for the FH012 mosfet regulator for the tighter voltage control and cooler operation. I bought an unused roadstercycle.com kit from someone here on Stromtrooper. Here is what I got;



That is the FH012 R/R, AWG 10 red and black wire to connect the regulator output directly to the battery, 30A circuit breaker and the connectors and plugs that fit the regulator. Since the new regulators run so much cooler than the old ones I decided to move it behind the left rear quarter panel. Its a perfect spot for it because there are already mounting holes in that sub-frame bar so no drilling and plenty of room for those wires. Here is what it looked like at some point during the install to give you an idea;



The red wire runs from the the regulator pos. output (green oval) and loops around the starter solenoid to the far side of the circuit breaker that I wedge behind the solenoid (yellow circle). The power lead then continues from the near side of the circuit breaker into the quarter panel area and then back to the pos pole of the battery. For the ground wire there is a little tunnel underneath where I put the circuit breaker to cross over to the right side of the bike and then back to the neg pole of the battery. The kit did not come with any protective sheathing but I installed some to protect it from abrasions & etc. I also crimped, soldered and heat shrink wrapped all the connectors to insure secure connections.

The next thing I needed to do was connect the phase wires coming out of the stator to the new regulator. I unplugged the phase wires from the old regulator (very difficult) plus the crankcase position sensor wires and then feed them back across the cylinders so they were on the left side of the bike. The good news is that the phase wires are long enough to reach the location of the new regulator without extending the wires. The tricky part is that I still needed to somehow separate the phase wires from the sensor wires as they are paired together in a protective sheath for the run between the cylinders to the right side of the bike.



To get the sensor wires out of the sheathing I needed to remove the connector. I smashed the end of a paper clip with a hammer to make a small flat tool to use to release the metal clips from the plastic connector. (I don't have a photo but if anyone wants to see how that is done I can post it later). The connectors are held in by a small tab and the paper clip tool presses down the tab and the metal clip is released from the plastic connector. The wires in the sheath are in there pretty tight but I was able to pull the green wire out of the sheath. You can see the green and white sensor wires to the left in the yellow circle back where they come out of the crankcase. One mistake I made was that I pulled the green wire (with the metal connector on its end) through the sheath with out wrapping it with tape. The small tab that holds it in the plastic shell was completely bent backwards. I got really lucky and was able to bend it back without breaking it which is not usually the case because the little tabs are very brittle and fragile. With the green wire out the white wire came out of the sheath easily (though I did tape it) and then I fed them into a sheath I had from my old, recently replaced stator and ran them back across the cylinders and installed the metal clips back into their plastic connector and plugged it into its mate on the right hand side of the bike.

The last step was to get the phase wires shown in the red circle plugged into the input to the regulator show in the green circle. I used the paper clip trick to release these metal clips from the plastic connector as well so I had bare connectors. The kit came with a large gray connector (first photo) that mates directly to the R/R input connector with crimp on connectors. The (minimal) instruction sheet says that those connectors should be for AWG 14-16 wires but I think my kit had all giant AWG 10 connectors for the power leads and were far too large to crimp onto the skimpy phase wires coming from the stator. Fortunately, the phase wires were long enough to reach the stator input and the OEM connectors fit the regulator input tabs perfectly so I didn't need the gray connector. All I had to do was shrink wrap each phase connector to prevent shorts and put a band of rubber electrical splicing tape to form a seal into the regulator input connector and some dielectric grease to keep water out and I was done.



Here is photo from the right side of the bike, all buttoned up. You can just see the fins of the R/R peeking out under the left quarter panel. I went for a shakedown cruise and everything seemed to be working good. Idle voltage was decent (12.6) but any RPMs over 2000 and I am getting 13.8V (it might be a little higher at the battery due to voltage drop to my meter). When I got back from my test ride I lifted the seat and felt the R/R and it was barely warm so I am not too worried about it melting anything or not getting enough air flow.

Caveats: This was not a terribly difficult project but its not for beginners unless you are willing to learn and don't mind your bike being out of commission for a few days as you order extra parts or whatever. The kit was fine for me but I have some experience at crimping, splicing and shrink wrapping connectors but not a lot and my skills are poor. To do it right I really have to slow down so the project actually took me about 6 hours, only an hour of that was dealing with the phase wires and crank position sensor wires which involved no crimping, soldering, etc. If you don't have those skills then this project is fraught with pitfalls that could leave you waiting for parts. The problem with a kit is that it is a high-wire act and one false move with the crimp or solder or wire cutters and you will be stuck, there isn't a lot of room for mistakes. Another issue, and a reason I don't like electrical projects, is that you have to be very careful before you cut wire or commit to a specific plan. Because of this I kept having to install and reinstall everything to make sure everything was going to fit as planned as I worked along. If carpentry is measure twice, cut once then custom wire projects are this time ten. Also, working with that AWG 10 wire is not like working with regular wires, it is thick and heavy and hard to make go where you want it to go. Put it in a sheath and it is even more so. Also, you'll need serious soldering power to solder 10 gauge wire. I think mine is 150W so if you have a smaller 40-50W soldering iron that won't work.
 

Attachments

·
Registered
Joined
·
810 Posts
Discussion Starter #2
Rookie Mistake

FYI, I was working on my bike today and I discovered I skipped an important step on my R/R install. I unplugged the phase wires from the old regulator but I forgot to unplug the power output connector to the old regulator. Hopefully it didn't damage anything but everything seems to be fine and it does seem to have better volts at idle now but I'm not certain about that.
 

·
Super Moderator
Joined
·
16,877 Posts
Horrible location IMHO for the R/R there, it gets little to no moving air hitting it aiding in cooling.
 

·
Registered
Joined
·
810 Posts
Discussion Starter #4
Horrible location IMHO for the R/R there, it gets little to no moving air hitting it aiding in cooling.
Its a mosfet R/R, it doesn't get as hot as the OEM R/R. Road grime gets in that side panel so I have to assume there is some air circulating in there. Hey that could be my next project with my new temp probe, measure the temp of R/R after the move!
 
1 - 4 of 4 Posts
Top