StromTrooper banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
New member from Calgary, Alberta! I found this fantastic forum the same day I bought my first V-Strom this week. It's a 2014 DL650A, and it came with oodles of accessories and only 2300km on the clock. The original owner had not ridden the bike since 2015, due to personal issues. The only concerns I have are: 1) the first oil change had not been done, and 2) the gas in the tank didn't have a stabilizer added. On the ride home the red FI indicator came on, but I'm pretty sure that's due to a gummed-up injection system. Hopefully there's a safe fuel additive available that can deal with that.
 

·
Registered
Joined
·
749 Posts
Congrats on your 'new to you' V and welcome Hank.

Just remember - witthout pics it never happened.
 

·
Registered
Joined
·
480 Posts
Hello and welcome.

Yes, if its not to late, drain old fuel and replace with fresh gas. Confirm there is no corrosion (rust) inside fuel tank utilizing a flashlight. If all looks good find a good fuel additive.

Change your engine oil.

Change your brake fluid and cycle the ABS system a few times afterwords.

Change rad fluid with a good quality long life antifreeze. I get mine from the Toyota dealership (pink) but you can use Suzuki (Blue) or Honda (?).

Used the Google search box on this site to guide you through the process of all the above.

Have fun!
 

·
Super Moderator
Joined
·
13,057 Posts
Welcome aboard Hank!

Great riding out there!

You might want to stop over in the Canadian Section in Regional Forums and say hello. There are some Strommers local to you.

..Tom
 
1 - 7 of 7 Posts
Top