StromTrooper banner

1 - 9 of 9 Posts

·
Registered
Joined
·
72 Posts
Discussion Starter #1 (Edited)
I was having a problem with my Coocase. The alarm, lights, open-close feature would only work if I pushed down on the lid. I removed the case and popped out the connector assembly on the bottom of the case. I found that two of the three connectors were no longer soldered to their respective brass connectors--just barely touching the connectors. I soldered the wires back to the connectors, and now all functions have returned. I thought if you notice your Coocase lights, alarms, or other features not working, you might want to check the connectors on the bottom of the case.

 

·
Registered
Joined
·
194 Posts
Now all I have to do is hook mine up and wait for it to stop working. :thumbup:
 

·
Registered
Joined
·
180 Posts
Would you still buy the Coocase, knowing this now? (I don't have a problem with a little soldering, though.) I guess I'll remain in wait-and-see mode for a nice top case suitable for the ADV model, otherwise.
 

·
Registered
Joined
·
72 Posts
Discussion Starter #4
Would you still buy the Coocase, knowing this now? (I don't have a problem with a little soldering, though.) I guess I'll remain in wait-and-see mode for a nice top case suitable for the ADV model, otherwise.
Yes, I really like the case. It works as advertised and is just the right size for me. I did a Google search for this problem and found other's had the same fix.
 

·
Official Stromtrooper.com Sponsor
Joined
·
5,352 Posts
My experience with my new CooCase is the same. Twice I noticed the lock/unlock wouldn't work. I had to resolder the wires for that connection ( second time I thought I did a better job....) and on the trip to WV recently my son said the tailight in the case started blinking.....

When I got back all three wires were broken off at the copper slide connectors in the base. I cut the factory wires and added some wire to those to make it easier to work on. I carefully cleaned and soldered everything again. If it happens again I'll resolder it and pack it with silicone to keep it from moving around.

Definately not a "robust" design.....
 

·
Registered
Joined
·
128 Posts
While on trip to Maine NH VT MA oh and Canada,..today all in 16 hours true story it was great, I notices my top case works when it wants too and now just won't do anything lights or alarm or lock unlock with remote. Glad u posted this I will check the box under top case or box inside top case under liner ? Thx.
 

·
Registered
Joined
·
253 Posts
If you should have this problem email us with a picture of the broken connector and a proof of purchase. Your name and address should be plenty if you purchased it directly from Twisted Throttle. We will happily send you out a replacement connector.

We also sell a Base plate wiring harness if you should need to replace that one as well.



Kevin
 

·
Official Stromtrooper.com Sponsor
Joined
·
5,352 Posts
Thanks for the information Kevin. Do you know if there has been an improvement in the design?
 
1 - 9 of 9 Posts
Top