StromTrooper banner

1 - 6 of 6 Posts

·
Registered
Joined
·
329 Posts
Discussion Starter #1
My OD light has been coming on in the wrong gear for many miles now, and I have noticed lateley that when it comes on in 3rd or 4th at steady light throttle that the bike surges ahead slightly when the light comes on and holds back when the light goes off. Has anybody changed out the sensor, or bypassed it with a TRE? K3 Vee all OEM. Thanks!
 

·
Registered
Joined
·
16 Posts
Interesting post. I did not notice the OD light coming on until I was riding at night, it flickered on and then off. Was not sure it was the OD or Neutral light. I was in 5th on a 3K Vee. Not helpful to your situation, but some collaboration that it is happening.

Bryn
 

·
Registered
Joined
·
3,382 Posts
The gear position sensor for the Vee is inside the engine. It's a simple variable resistor, and over time, heat and wear and maybe dirt or varnish change the resistance values from what the system "expects" to see. As you noted, the OD light comes on early, and you can sometimes feel a slight change in the way the engine runs, since 6th gear uses slightly different mapping. There's also a speed restriction in 5th and 6th gears.

The easy solution is to plug in an Ivan's TRE. It gets rid of that damn stupid bright green &^%$#@! useless OD light, and any time you're not in neutral, it tells the FI system you're in fourth gear. The engine runs a bit better, and the speed restriction is gone.

If you have the clutch out anyway for some other reason, you could also try replacing the sensor. I don't see the point, really -- much easier to install an Ivan's TRE and be done with it.
 

·
Registered
Joined
·
16 Posts
Thanks for the reply. I searched the Ivan's TRE, which helped explain some other issues I have with the bike.

Thanks

Bryn
 

·
FORUM GODFATHER.....R.I.P. PAT
Joined
·
38,048 Posts
1 - 6 of 6 Posts
Top