StromTrooper banner

1 - 10 of 10 Posts

·
Registered
Joined
·
236 Posts
Discussion Starter #1
Wondering if anyone else has had this bug. I was unable to get my right rear luggage bag to open, the key worked the lock but that was it. I struggled for over an hour, removed the bag and then finally got it to open. Looking in the opening I could see where part of the locking mechanism metal plate had slide sideways and blocked the two parts from separating. By shaking the bag I let gravity pull the loose plate back into the void. I have not had the opportunity to find a fix, but this can be a real annoyance and I thought that I was going to need a bungee to secure it. Just looking for anyone who has had this problem. 2014 DL1000.
 

·
Registered
Joined
·
632 Posts
Wondering if anyone else has had this bug. I was unable to get my right rear luggage bag to open, the key worked the lock but that was it. I struggled for over an hour, removed the bag and then finally got it to open. Looking in the opening I could see where part of the locking mechanism metal plate had slide sideways and blocked the two parts from separating. By shaking the bag I let gravity pull the loose plate back into the void. I have not had the opportunity to find a fix, but this can be a real annoyance and I thought that I was going to need a bungee to secure it. Just looking for anyone who has had this problem. 2014 DL1000.
No help here, but I am not surprised. I have thought from the day I bought my new 2015 model that the locking mechanism was cheap and finicky. Really miss my old GIVI 35's on my VFR800.

Sent from my XT1254 using Tapatalk
 

·
Registered
Joined
·
204 Posts
Wondering if anyone else has had this bug. I was unable to get my right rear luggage bag to open, the key worked the lock but that was it. I struggled for over an hour, removed the bag and then finally got it to open. Looking in the opening I could see where part of the locking mechanism metal plate had slide sideways and blocked the two parts from separating. By shaking the bag I let gravity pull the loose plate back into the void. I have not had the opportunity to find a fix, but this can be a real annoyance and I thought that I was going to need a bungee to secure it. Just looking for anyone who has had this problem. 2014 DL1000.
Had the same problem with mine when new. That plate slides too easily and blocks the latch from opening. I squirted a healthy dose of white lithium grease into the area where the plate slides around and now it stays where it's supposed to. The grease keeps it in place but allows it to move for function. Not the greatest solution, but I'd say the design is pretty poor.
 

·
Registered
Joined
·
236 Posts
Discussion Starter #4
Thanks RCE, a humorous story as this happened on a hot day in the dark,lower level bowels of a goverment parking garage in DC. So for a country boy struggling with this on my first long cross country trip to a big city on a busy weekend I thought surely I would be in prison!!!! Then after that fiasco and sweating like mad from summer heat the automatic exit gate would not recognize my bike!!! So I backed up , let the next car go thru and stuck to his bumper to escape. Still wonder how I got away!!! If security had been on the ball they would have wondered about the weird guy on his knees, possibly arming the luggage, haha
Thanks for the tip on the fix, I will play with it in the warm living room this winter.
 

·
Registered
Joined
·
1,615 Posts
I had that problem too. In my case, on a trip, I couldn't get it to latch closed. Three of us fiddled, jiggled, coaxed and cursed until finally used everyone's extra bunji cord to hold it closed. It was still on warranty so I asked the dealer in Vallejo (great guys) to help me fix me. He kept it for a couple of days and eventually replaced the whole thing.

There is another thread somewhere about this but with the only recommendation being the white grease as RCE1 mentioned. On another forum someone had permanently "located" the plate with a pop-rivet.
 

·
Registered
Joined
·
7 Posts
I also had the same problem. I noticed that the silver plate was blocking the locking mechanism. The plate would slide back into place when I tipped the case on its side and tapped it. I might try the lithium grease suggestion. This has happened twice so far.
 

·
Registered
Joined
·
265 Posts
Add one more to the bunch ... I have identical problem with my '15 DL1000. Before bring it back to Suzuki, I'll try the lithium grease.
 

·
Registered
Joined
·
266 Posts
I haven't used my case locks yet but if they are anything like the ignition I can sympathize. I'm always struggling with the ignition not turning or turning too far or having difficulty fitting the key in. Pretty cheezy set up.
 

·
Registered
Joined
·
3 Posts
My 2016 DL1000A V has the same issue. Currently in the shop getting new cases installed. we noticed a small pin like rivet that is on my bags, but not on the new one. Both sides now doing the same thing. Need to carry small screwdriver to manually slide the receiver plate out of the way and if you are not careful it locks into the other side, blocking taking the bag off the bike. Waiting on Suzuki reps response. Nearly broke key off on first day with the bike. I like the bike but the OEM bags and locks clearly have an issue. Under warranty at least, but...
 

·
Registered
Joined
·
632 Posts
Solution for me...Happy Trails SU racks with Aluminum cases. Bullet proof, industrial strength, quality. Suzuki OEM is cheap, pathetic and toy-like. The FJ-09 has the same poor quality plastic boxes, probably same Chinese mfgr.

The only thing about the bike that I really thought was poorly done to the point of a rip off...
 
1 - 10 of 10 Posts
Top