StromTrooper banner

1 - 10 of 10 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
:furious: SO my 2005 650 wee is acting up and i dont know what to do :confused: it will not idle good and will drop a cylander at idle
SO LETS GO OVER ALL I HAVE DONE
PLUGS,AIR FILTER,COMPRESSION TEST,LEAK DOWN TEST,SWAP COILS AND PLUG CAPS,
I AM GOING TO DO A FUEL PRESSER TEST LATER TODAY
MY WEE IS GOING ON 58000 MILES WITH NO TROUBLES OTHER THAN THE HIGH BEAMS QUIT FOR A BIT :thumbup:

NOW LET ME TELL YOU ALL THE SYMPTOMS
ROUGH IDLE AND SLUGGISH OFF TAKE OFF ANYTHING UNDER 4000 RPM IT IS ROUGH IF YOU POUR THE COAL TO HER ABOVE 4000 SHE RESPONDS WELL IF YOU ARE IN TO TALL OF A GEAR AND POUR THE COAL TO HER AND RPM IS UNDER 3 TO 4000 RPS SHE DROPS A CYLANDER UNTIL YOU LET OFF TO HALF THROTTLE THEM SHE WILL PICK IT BACK UP AND RUN PROPERLY IF YOU DOWN GEAR UNDER POWER IT WILL PICK THE CYLANDER UP AND RUN PROPERLY
ANY HELP WOULD BE GREAT
 

·
FORUM GODFATHER.....R.I.P. PAT
Joined
·
38,104 Posts
Check for an air leak too. Spray the throttle bodies with starter fluid and see if the idle changes. If worried about fire, use WD40 and check the exhaust for smoke instead.
 

·
FORUM GODFATHER.....R.I.P. PAT
Joined
·
38,104 Posts
Not carb cleaner, starter fluid, ie. ether.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
still no change in my wee did fuel presser teat and it is good. now kind of leaning to a bad injector? or clogged. ignition spark test seemed to be fine never lost fire when symptom started...
 

·
Premium Member
Joined
·
3,140 Posts
I know it's a longshot, but could either the clutch or kickstand safety switches be causing an intermittent kill-order to the ignition [due to random vibration], and when the rider backs off, the safety switches are knocked out of their 'bad' vibe range, allowing the bike to perform normally - till the vibes affect the switches again?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #10
put and ran one tank through it thinking it would clean it out but no change this all started when i took a trip on some super dusty roads road about 45 miles of cant see anything dust super cool...but now ive had nothing but troubles for about 500 miles problem did not start till a week later

thanks
 
1 - 10 of 10 Posts
Top