StromTrooper banner
1 - 5 of 5 Posts

Registered
2007 V-Strom 650
Joined
18 Posts
Discussion Starter · #1 ·
Hey Guys, Just traded out my Kawasaki Vulcan 1500 for a 2007 V-Strom 650. Jumped from Star Trek to Star Wars ha.

I am located in Tampa, FL and this is my second bike.

I knew I wanted something more geared toward adventure. My Wee has about 26,000 miles on it. I have heard they make it to 100,000 regularly. Only issues I am seeing with the bike is it looks like there is a broken rear wheel sensor for the ABS (I think) and something happening with the electrical in the dash. The dash resets while riding, no issues with rideability though. Most likely a chaffed wire or short somewhere. While riding, the longest the dash went without resetting was about 15 minutes, but the clock did not reset over night at all. 馃

I am planning on doing a tune up this weekend. New oil, plugs, air filters, check the chain tension. Anything that I should be looking out for with these bikes? Any must have modifications?

It looks like they have added quite a bit to it already. It came with hard sided bags, fog lights (inoperable), a usb charger port/voltage regulator (inoperable I think(possibly stock)), Skid plate, engine guards, a sargent seat, and most importantly a stromtrooper sticker.

Thanks in advance for any help and nice to meet you all!
Tire Wheel Fuel tank Plant Vehicle
 

Registered
2007 V-Strom 650
Joined
18 Posts
Discussion Starter · #10 ·
Welcome to the forum, gusbus.

For your electical/dash problem, you might check the big black rubber boot covering electrical connections on the left side front under the tupperware, it has been known to have some burned connections for some folks. Also, trace those electrical additions from the previous owner.



View attachment 294369
I am going to be doing a big inspection/maintenance this weekend. Take off all the fairings and look over everything. I have seen that the are you mentioned on the left side is a common issue for the electrical. I do not think it is anything major, probably just a loose connector.
 

Registered
2007 V-Strom 650
Joined
18 Posts
Discussion Starter · #11 ·
Welcome, I'm down in North Port. I just joined the Strom club. you got some killer roads not far from you, in the Brooksville area. I bang around down in Arcadia up to Myakka city gas Station on Sunday mornings, it a cool place to meet fellow riders.
Thanks for the welcome! What kind of roads are down that way? On the last bike I usually went North to try and find some twisties and kept running into gravel roads, which made me want and ADV bike.
 

Registered
2007 V-Strom 650
Joined
18 Posts
Discussion Starter · #12 ·
Welcome to the forum! Yes, they'll go 100K miles easily, I have 101K miles. I hope you get you're electrical issues sorted out. Speaking of, these bikes are known to have stators that fail prematurely, a volt meter will let you monitor your charging system. Also headlights are also known to fail due to excessive voltage running through the starter switch, the fix for this (before it happens) is a headlight relay available through Eastern Beaver. Other than that they'll run forever with basic maintenance.
I was planning on converting to LED all the way around. Not sure if that will still be an issue or not.
 
1 - 5 of 5 Posts
Top