StromTrooper banner

1 - 5 of 5 Posts

·
Registered
Joined
·
273 Posts
Discussion Starter #1
Just ordered some Mo-tech bars for my Vee.

1. Do I need to replace any mounting bolts?
2. What type of lock-tight should I use?
3. Any gotchas?
 

·
Registered
Joined
·
1,042 Posts
I don't know about a Vee, but I just got thru installing them on my Wee, yes you have to replace the mounting bolts, but all the replacement hardware I needed came with the Crash bars. I installed one of the optional washers (supplied by SW-Motech) on each side on the long engine mount bolt. I used blue Loc-Tite, it's pretty straightforward just study the diagram real good and make sure you have all the hardware before beginning.
 

·
FORUM GODFATHER.....R.I.P. PAT
Joined
·
38,047 Posts
The big washers are about the only variable. Use enough washers to make sure the bars rest on the washers or spacers rather than the frame members. On my '05, 2 on each side were required and on my '07, one on each side did the trick.
 

·
Registered
Joined
·
1,820 Posts
I used no extra washers or loctite on my '05. Everything came together nicely.
 

·
Registered
Joined
·
8 Posts
Installed mine about a week ago in about 30 minutes. I never expected them to go on so easily!

The only difficult part was removing the allen head bolts at the upper connection point. The factory bolts were put on by gorillas with blue loctite. It took some serious leverage.

Once on, they "fit" the bike much more than I expected. I really like the way they look.

Best of luck.
 
1 - 5 of 5 Posts
Top