StromTrooper banner

1 - 13 of 13 Posts

·
Registered
Joined
·
1,429 Posts
Discussion Starter · #1 · (Edited)
Okay, so it is winter so I have been pretty much riding to and from work for the last couple months. Before that I returned from my Alaska trip and got pretty abysmal gas mileage. I chalked this up to a heavy load and a heavy headwind.

That leads us up to this weekend. It was 60 degrees on Saturday and the family had to go to Ohio for a christmas with the in-laws. I opted to ride and hopped on the bike. I filled her up with premium (the prices were so low in comparison why not?) and headed out. I noticed pretty quick that I was doing a GPS 75MPH and my speedo was going NUTS. Jumping from 90MPH to 100MPH constantly. On the return trip I had to fill up!! That means on a tank I got about 150 miles!

So my question is:

Really bad gas mileage plus speedo jumping all over the place. Related? Unrelated? What should I start looking at?

Any input will be appreciated.

-GW
 

·
FORUM GODFATHER.....R.I.P. PAT
Joined
·
38,103 Posts
Winter mileage issues were covered in http://www.stromtrooper.com/forums/showthread.php?t=34147

The speedo problem is most likely a marginal connection unless you are getting a trouble code. If it happens again, don't turn off the ignition and short the dealer mode plug to check for trouble codes.
 

·
Registered
Joined
·
1,429 Posts
Discussion Starter · #3 ·
This is a lot more then winter mileage issues. I went from mid 50's to mid 20's.

HUGE.

P.S. How is my new avatar?
 

·
$tromTrooper
Joined
·
1,741 Posts
Mileage and a Speedo problem....could be related....

I suppose the first thing I would do is check the odometer against a GPS. This is the only test I know of to eliminate the possibility of a faulty speedo or speedo cable.

If your mileage really sucks that bad....then maybe you need a tune-up after your Alaska trip....not to mention a new air filter.


Ahhhh and the new avatar.....that is a Wolf in Alaska!!!!!
 

·
Registered
Joined
·
1,376 Posts
If the bike is truly out of gas the speedometer or odometer is not going to fix it, dirty injectors maybe, junk fuel, failed air temp sensor, thermostat stuck open .:confused: Get out the manual and see what can cause the system to think the engine is cold. Those are thought starters if you find the cause on your own you will always remember, then again if you play on GW's sympathy he may tell you how to fix it.
 

·
FORUM GODFATHER.....R.I.P. PAT
Joined
·
38,103 Posts
If there is a bad connection or a malfunctioning instrument package, you can't trust the speedo, odo or fuel gauge so it's hard to figure your mileage on one fill up. Premium may hurt your mileage too. It tends to be older because it isn't used as much. It does not burn as easily either. A FI problem can default to a fail safe mode which can have a marked effect on mileage. You may also have a dirty air filter.
 

·
Registered
Joined
·
1,429 Posts
Discussion Starter · #9 ·
A few things fell into place today.

1. Turning on the bike this morning the fuel pump wasn't just loud, it squeeked. I'm thinking this might contribute to my mileage issues.

2. I noticed today that when I let off the brake my speedo did the jump around thing. I'm thinking this is directly related to the relay I put in so I could run LED taillights and my CC100. I've got the cruise control disconnected at the moment and put bulbs back in the taillight. I think I need to get rid of the relay and stick with the bulbs.

I'll post up if those fixes work when I get a chance to work on the bike. It will not be for a couple weeks.

-GW
 

·
FORUM GODFATHER.....R.I.P. PAT
Joined
·
38,103 Posts
All the relay does is to provide a path to ground for the CCS 100 when the brake is not on. It should have no effect on the speedometer. Mine works fine with the relay.
 

·
FORUM GODFATHER.....R.I.P. PAT
Joined
·
38,103 Posts
Yes but you installed that one....

-GW
And I got it right the second time. The first time it threw an FI code. The black wire I thought I remembered being ground when I used it as a clutch relay wasn't. :frown2:
 

·
Living the Stereotype
Joined
·
11,544 Posts
This is a lot more then winter mileage issues. I went from mid 50's to mid 20's.

HUGE.

P.S. How is my new avatar?
You look like Adam Sandler now.

Clutch slipping?
 
1 - 13 of 13 Posts
Top