StromTrooper banner

1 - 4 of 4 Posts

·
Registered
Joined
·
186 Posts
Discussion Starter #1
I purchased the Madstad standard windshield mount for my bike. I arrived yesterday, and I tried to install it today. I have run into a problem. I am at the point where you mount the windshield on the new brackets, but the brackets appear to be spaced about 1/4 inch wider than the holes in my windshield. I have tried to see if there is some play in the alignment by loosening the bolts that hold the brackets in place, but there isn't enough there to make a difference. I am having this alignment problem with both the stock windshield and the replacement Givi I just purchased. Has anyone else had a similar issue with the alignment of their Madstad mount? Thanks.

Longsnowsm
 

·
Registered
Joined
·
416 Posts
I seemed to have an alignment problem. But I left the Madstad knobs loose. The shield has a curve. I just pressed the curve down and started screws one by one. It aligned up and I tightened it down. I had a similar problem with my FJR and a replacement screen. Warm the shield to room temperature and it flexes more easily.
 

·
Registered
Joined
·
186 Posts
Discussion Starter #3
Thanks Mike! I went back out and "persuaded" the bracket to line up. It is finally mounted. Thanks for the heads up on the mounting technique.

Longsnowsm
 

·
Registered
Joined
·
961 Posts
I had a problem with my Madsted moving as I rode along, no matter how I tightened them. I stopped at home depot and got 2 star washers, stuck them between the brackets no more movment.
 
1 - 4 of 4 Posts
Top