StromTrooper banner
1 - 5 of 5 Posts

· Premium Member
Joined
·
4,349 Posts
Discussion Starter · #1 ·
The clutch lever on the DL1K is different than on the Wee obviously, so i wanted to ask this in here.

My clutch lever needs lubing. I can feel it kind of sticking, or crunching when being used.

As this is hydraulic, i want to be sure to do this correctly. Is there a problem just removing the screw holding the lever on and pulling it out to clean/lube?

I haven't looked at it yet, thought i would just toss the question out. I'm sure some of you guys have done this a million times before.
 

· Registered
Joined
·
3,864 Posts
Go ahead -- it's all very straightforward.

Just pay attention to how the pushrod attaches.
 

· Official Stromtrooper.com Sponsor
Joined
·
5,932 Posts
I would add that putting grease on the brass bushing that actuates the pushrod is just as or more important than the mounting point of the lever. Very simple job, pushrod is held in place by a rubber bellows, blunt end goes in the clutch master cylinder.
 

· Registered
Joined
·
9,982 Posts
lately

Changed your clutch fluid lately? Does it look a bit tea-like through the sightglass? It is my impression that the fluid becomes a bit less slippery as it ages/collects moisture,giving the feeling of sticky/hard clutch pull, not to mention that collected fluid will eventually start corroding parts that need to seal. Lubing the pivot is also important, but grungy old fluid won't help the cause.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top