StromTrooper banner

1 - 11 of 11 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter #1
I have a 2014 V2. Lately when I hit a good bump I get a loud bang or knock. It is not in the brakes or suspension. I think it is something slapping around in the instrumentation cluster under the wind screen. Much louder if you apply brakes when going over rough pavement. Any one else? IS there a known issue? If so is there a fix?

SL
 

·
Registered
Joined
·
1,325 Posts
Had similar knock on Wee2 drove me crazy. Actually took plastics and tank off. Turned out extra keys/keychain hitting on a black plastic around lock.
 

·
Registered
Joined
·
3,223 Posts
Steering stem bearings loose?

Also the steel frame that holds the whole front instrument assembly is fixed to the frame by 2 bolts that like to get loose. See if there is any play there.
 

·
Registered
Joined
·
11,528 Posts
That's a new one for me with a 2014 V2.

I FARKLE'd the heck out of my bike up front with mounts, radar detector, two sets of LEDs, etc. and the dash as well with four new wire harnesses. Also added the crash bars, radiator guard, Givi Airflow - MRC, a camera and two phone mounts plus a dual USB outlet. Still sounds the same.

That is strange. Do you ride a lot of hard off-road?

Front brake? Does it do it with the just the rear brake alone?
"Much louder if you apply brakes when going over rough pavement."
 

·
Registered
Joined
·
202 Posts
Check the fairing bolts where they attach to the steering tube. I noticed a lot of vibration (fairing was vibrating up and down) on my first really long ride. I thought it was just the wind, but then later realized one of the two bolts fell out and the other was just a few threads short of joining the first.


Sent from my iPad using Tapatalk
 

·
Premium Member
Joined
·
4,232 Posts
Check the fairing bolts where they attach to the steering tube. I noticed a lot of vibration (fairing was vibrating up and down) on my first really long ride. I thought it was just the wind, but then later realized one of the two bolts fell out and the other was just a few threads short of joining the first.


Sent from my iPad using Tapatalk
I can't think of anywhere a fairing attaches to anything related to steering, do you have a picture of that someplace maybe?

I was thinking maybe someone forgot to put the two screws into the front of the gas tank behind the fairings, they are a bit difficult to get to. Maybe the tank is flopping up and down when you hit a bump?
 

·
Registered
Joined
·
3,942 Posts
I can't think of anywhere a fairing attaches to anything related to steering, do you have a picture of that someplace maybe?
?
Directly below your ignition switch.

I had one of those bolts come out on me Wee, I was parking the bike at the time and my steering jammed up. :furious:
 

·
Registered
Joined
·
6 Posts
Directly below your ignition switch.

I had one of those bolts come out on me Wee, I was parking the bike at the time and my steering jammed up. :furious:
Must have been pretty scary, I guess...

Sent from my m2 note using Tapatalk
 

·
Premium Member
Joined
·
4,232 Posts
Directly below your ignition switch.

I had one of those bolts come out on me Wee, I was parking the bike at the time and my steering jammed up. :furious:
This is V2 forum. There is nothing in that location except a metal tubing frame that goes forward to hold beak on and maybe some other stuff.
 

·
Registered
Joined
·
729 Posts
I used to get a bang out of the front of my '06 Wee when I hit potholes, especially under breaking. When I had the front wheel off for a tire change, I decided to change the fork oil, it was clearly old oil and maybe not quite full, but I never get that noise anymore. (My son owns it now).
I doubt if this is the issue on your bike, it's much newer, but it's worth a mention.
 
1 - 11 of 11 Posts
Top