StromTrooper banner

1 - 2 of 2 Posts

·
Registered
Joined
·
192 Posts
Discussion Starter #1
Those of you with 2004s and all those engine complains might want to check out and scroll down to the end http://11109.rapidforum.com/topic=101080745851&startid=2#unten

One of the guys over there is encouraging V-Stromers with similar problems to mount a campaign of complaints with the U.S. NHTSA, which I'm guessing is National Highway Traffic and Safety Association. He's making the argument that the problem is a safety issue and figures if enough complain then Suzuki can be forced to do a safety recall and really fix the problem.

Just passing this along. Mine's a 2002 and runs beautiful.

Bob
 
P

·
Guest
Joined
·
0 Posts
Just got my '03 DL1000 back from its 7500 mile service. New air cleaner went in - the old one looked pretty grim - full of dead bugs and junk. New plugs. Also had a throttle body sync done. Runs sweet. It has always run good, but its running better than ever now. Very smooth. The TBS cost me an hours labor, but it has made a big difference, particularly at low rpms. Put Silkolene synthetic oil in, and the tranny is shifting very smoothly - noticable difference.

I don't see where there is anything wrong by design with this bike, but I think poor setup at the factory & dealership could be causing a lot of the issues that some experience. The results of the service work really made a big difference - worth the investment.

I also had the new Dunlop 607s mounted. Haven't scrubbed them in yet, but it does seem to ride better.
 
1 - 2 of 2 Posts
Top