Strom Trooper banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
So the LCD panel for my 05 dl650 is completely dead along with the spedo and tach. Everything else seems to work fine though and the engine still runs. Where should I start looking?

Thank you.
 

·
Super Moderator
Joined
·
4,934 Posts
I suspect a poor or corroded connection in the wiring. You will need to take off the faring and open, inspect and clean all of the terminals behind the dash. The large plug LH side of the steering head is also known to be susceptible to corrosion.
I am assuming that you have done nothing to the bike lately. Look first where the human was last.
 

·
Registered
Joined
·
14,018 Posts
What Brockie said.The old Wees are easy to take apart and you should get to know the innards. Take loose the fairing and start wiggling wires.
You might invest in a tube of dielectric paste. It helps keep connectors working.
 

·
Premium Member
Joined
·
3,457 Posts
You will have to take some tuperware off, but I'd start where the harness plugs into the instrument cluster....it will be right behind the cluster. With a multi meter see if you have power to that plug with the key on. If not, work backwards from there.

If I remember right, there is a waterproof sleeve that slips over the connector when connected....it might have vibrated off or was never installed properly letting water into it.
 

·
Registered
Joined
·
7 Posts
So the LCD panel for my 05 dl650 is completely dead was long with the spedo and tach. Everything else seems to work fine though and the engine still runs. Where should I start looking?

Thank you.
I had the same issue. Found the problem up front with the wiring harness for the instrument panel and lights (left side behind the headlight). Mine was just hanging in the rubber sheath. Pulled it, twisted the shorting connection and put a small bit of fine wire into the female end to mitigate the gap. Works great again. I zap strapped it to the frame up front to take the weight off so its not just hanging.

Good luck.
 

·
Registered
Joined
·
122 Posts
If you can't get it working, I have a spare speedometer assembly from an '06 that should drop right in. You can have it.
 
1 - 8 of 8 Posts
Top