StromTrooper banner

1 - 1 of 1 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Posted up on the 650 specific thread but got no replies, so I'll give it a try here:

I've been travelling in Mexico the last while on my way to Argentina. I'm having problems with the idle speed on my 2005 DL (19,000 miles).

At about 18k miles I noticed the idle speed dropped from 1500 RPM to about 800. It wasnt a huge problem so I ignored it until the bike occasionally started cutting out in traffic. After checking on this board I found out how to adjust the idle speed from the screw on the left hand side. Idle speed was back up to about 1300 RPM and all was right with world again.

However today the idle speed shot up to 2,000 RPM. It shut it off for a while and it went back down to 1300 RPM once I restarted. However after riding it a while longer it came back up to 2000 RPM.

Here are some of the variables that may or may not be the culprit:


- Bike has been fully maintained - I had the oil changed a few weeks ago at 18K and it is showing just at the full level when the bike is on the centerstand, Both the low idle problem and the subsequent high idle problem occurred after the oil change

- Temperature and Altitude - Up to a few days ago I was travelling along the coast where conditions are very hot an humid. Now I'm in San Cristobal De Las Casas, at 8,000 feet above sea level where the temperature is much cooler. Here is where I'm encountering the high idle problem.

- I'm leaning toward thinking there might be too much oil in the bike and its somehow affecting idle speed. However there might be other causes I haven't considered, so I want to ask the collective here before jumping to that conclusion.

Thanks
Conor
 
1 - 1 of 1 Posts
Top