StromTrooper banner

1 - 11 of 11 Posts

·
Registered
Joined
·
600 Posts
Discussion Starter #1
Hi Fellas
I am in the process of doing some maintenance.
My 2008 Canadian Wee appears to have only 2 spark plugs?
I thought they had 4 ?
 

·
FORUM GODFATHER.....R.I.P. PAT
Joined
·
38,103 Posts
There are four. You can see the two plugs on the sides. The others are buried in the center of each cylinder.

 

·
Registered
Joined
·
600 Posts
Discussion Starter #4
Got em all...that front plug was a bitch...easier to put on my Scotts Damper.
BTW I did the Scotts at the same time as the air filter and plugs.
Very staight forward....no filing to be done.
Now I just have to put the cowling back on.
 

·
Registered
Joined
·
1,571 Posts
Got em all...that front plug was a bitch...easier to put on my Scotts Damper.
Very easy to get at if you first remove the rad and it's cowling.:thumbup: While you are in there (if not too late) check to see if the drain holes on the center plugs are open.
 

·
Registered
Joined
·
600 Posts
Discussion Starter #6
Thanx for the tip...if I ever do it again I will remove the rad fro the frame.
I just undid it and swung it out a bit, tough job.
I put Iridiums in and don't plan to change 'em for quite a while.
 

·
Registered
Joined
·
1,571 Posts
You may want to check the back of your rad to see that most of the fins have not been turned flat by your knuckles.:yikes:
 

·
Registered
Joined
·
600 Posts
Discussion Starter #8
Well, Bob, I did check....and sure eneogh...some of them did get bent...fixed as best I could...no overheating and it was hot as hell today.:headbang:
 

·
Premium Member
Joined
·
620 Posts
I just changed my plugs on the weekend... swinging the rad forward and using a bungy to hold it out of the way works fine *if* you use the spark plug tool provided with the bike... it's just the right length.

It took me less than an hour... mostly spent removing/reinstalling the tupperware. My 2005 only has two plugs though.

- Martin
 

·
Registered
Joined
·
600 Posts
Discussion Starter #11
Hi PSO sorry to take so long to get bak...about 10000 miles...were in great shape.
I put iridiums in and don't plan on changing them again for a long time.

Martin....What a maroon I am...never thought to use the "cheap" oem tool kit.
Used a generic plug socket with a short extention...still too long...hence the knuckle marks on the rad....who knew?....nice catch....if I ever do 'em again I hope I remember this post!:jawdrop:
 
1 - 11 of 11 Posts
Top