StromTrooper banner

1 - 3 of 3 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter #1
:headbang: Both headlights are out on my buddy's DL650K7. Fuses are good. Bulbs are good. Doesn't appear to be a relay anywhere in the circuit. Both high beams and low beams are out. All other lights and electrical stuff works.

First noticed them out while on a very bumpy road.

We're 1500 miles from home, and 250K from a Suzuki dealer!

Any ideas where there's a connector that could have come loose? Any suggestions?
 

·
FORUM GODFATHER.....R.I.P. PAT
Joined
·
38,103 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter #3 (Edited)
Headlights Working

:headbang: Both headlights are out on my buddy's DL650K7. Fuses are good. Bulbs are good. Doesn't appear to be a relay anywhere in the circuit. Both high beams and low beams are out. All other lights and electrical stuff works.

First noticed them out while on a very bumpy road.

We're 1500 miles from home, and 250K from a Suzuki dealer!

Any ideas where there's a connector that could have come loose? Any suggestions?
After my initial posting, I checked around on Stromtrooper and found the list of things to check. Sure enough, the problem was the headlight cutout that's built into the starter switch. Bad design. Fortunately, I found a solution elsewhere on this site before we started pulling off the gas tank, which would have meant pulling off the crash bars first.

Thanks to Eyecandy Custom Cycles] in Smithers BC & its friendly proprieter for letting us use his shop computer to surf this site, and then for helping us splice a connection using a twisted pair, shrink tube, and a butane lighter. It'll hold 'til we get home, then we'll fabricate a solution with relays.

It's little things like this poor switch design that remind me that our wonderful Stroms have a number of poor design choices that are intended to reduce costs. Fortunately, the engine is sweet, the frame size is right, the suspension is workable, and overall the bike is very reliable.
 
1 - 3 of 3 Posts
Top