StromTrooper banner

1 - 7 of 7 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter #1
After installing a set of Oxford heated grips with the direct to battery connection, I got a connector from Eastern Beaver and now have a "switched" connection - good idea for someone like me who WILL eventually, forget to turn them off. While making the change, I found TWO (2) unused connections - the wrong one first of course. Fortunately, Suzuki must have made things idiot proof and the "other" connection did not fit Jim's wiring harness. Just curious as to what the other unused connector is for??
Second question - when I first start the bike, if I turn the grip heaters on immediately, the blue light on the (digital) control flashes and it shuts itself down. I assume this is due to lack of power - once the bike has run for a minute of two, the heaters work fine. Is this a sign the battery is going (OEM on a 2005)???
My apologies if this has been dealt with before.
 

·
Registered
Joined
·
3,565 Posts
When you installed the fuse box, the hot is directly connected to the battery and the "switch" is connected to a relay right?
 

·
Registered
Joined
·
50 Posts
Discussion Starter #3
No fuse box - initially, I had the supplied wire (with inline fuse) direct to the battery. Now I have used the Eastern Beaver adapter cable that allows one to plug into the Suzuki connector. In both cases the symptoms are the same.
 

·
Registered
Joined
·
3,565 Posts
No fuse box - initially, I had the supplied wire (with inline fuse) direct to the battery. Now I have used the Eastern Beaver adapter cable that allows one to plug into the Suzuki connector. In both cases the symptoms are the same.
If you wired it direct to the battery and it doesn't work correctly I would think your heated grips have a problem. Hooking directly to the battery should make it work. If it doesn't you can stop right there and troubleshoot.
 

·
FORUM GODFATHER.....R.I.P. PAT
Joined
·
38,047 Posts
Oxfords shut down when available voltage is low. It could be a battery problem or just that the engine has to be running over idle to get things high enough.
 

·
Registered
Joined
·
362 Posts
connector from Eastern Beaver

I had to remove the connector from Eastern Beaver and wire direct to the battery. The voltage at the connector from Eastern Beaver was 1 volt lower than at the battery and the heated grip controller would shut off.
 
1 - 7 of 7 Posts
Top