StromTrooper banner

1 - 11 of 11 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #1
Hi guys started the bike up this morning and as soon as i pressed the start button the headlights went out. Got the little side lights but not main and dip beam. Checked the fuses for the headlights and both ok. I've seen a few answers when googling some say starter switch. One said a contact in the ignition switch. And others point to the block connection under the tank. How do i go about tracing where the fault is. Mine is a 2015 model only mod os heated grips wired into the heated grip terminal not the battery. Thanks guys.
 

·
Premium Member
Joined
·
3,399 Posts
I would look for a discolored connection or use a probe/meter to isolate it. It is often in the starter switch but not always. Lots has been written re this issue as you are probably finding out with your search.
 

·
Registered
Joined
·
2,856 Posts
Well you mentioned all the possible problems. What have you done to troubleshoot?

I would disassemble the starter switch first, since that is frequently the issue. If that is clean and has good contact you need to find the connector some were around the radiator I think on your bike and make sure it has good contact and is not burned.

If both prove not to be the problem, report back.

And then consider to order a headlight relay kit from eastern beaver, if he offers one for your model, not sure.
 

·
Registered
Joined
·
38 Posts
Discussion Starter #5
Looking like the starter switch if i push the start switch the lights come on and as soon as i release off they go again. Are the switches easy to open up its not going to come apart into a thousand pieces as soon as i take it off is it?
 

·
Premium Member
Joined
·
3,477 Posts
Looking like the starter switch if i push the start switch the lights come on and as soon as i release off they go again. Are the switches easy to open up its not going to come apart into a thousand pieces as soon as i take it off is it?
Be very careful taking the starter button/switch apart. There are plunger and spring metal contact strips and they are tiny. Drape something under the handlebar to catch the parts, take pic's as you go and open up the cluster. I took my '07's apart, and soaked the blackened contact strip in white vinegar for 5 min, rinsed and re-assembled. Then added the EB harness with relay's and I suggest getting a extra relay when you order the harness as I had one fail(rare).
 

·
Registered
Joined
·
432 Posts
Looking like the starter switch if i push the start switch the lights come on and as soon as i release off they go again. Are the switches easy to open up its not going to come apart into a thousand pieces as soon as i take it off is it?
What you describe is the reverse of what should be happening. When the starter button is pressed the lights go out to give more juice to the starter. Arcing at the contacts causes resistance which leads to more arcing. Have a look at the info on the forum and you will be fine
 

·
Premium Member
Joined
·
3,477 Posts
^ what he said.......if you don't it will happen again, in the rain at night, with no moon.....75 miles from home with an reeeel unhappy pillion.
 
1 - 11 of 11 Posts
Top