StromTrooper banner

1 - 10 of 10 Posts

·
Registered
Joined
·
276 Posts
Discussion Starter #1
My 2016 DL1000 has a missing 3rd and sometimes N indicator on my display. Best I can figure is the sensor needs to be cleaned or replaced. Has anyone done this before and what is the degree of difficulty? I am somewhat mechanical ( did my valve adjustments, sprockets and chain, etc.), but have never replaced or messed with clutch plates.
Thanks for any advice.
 

·
Registered
Joined
·
15 Posts
I have got the same problem at 80.000km. Replaced the sensor, it was not expensive.
Sensor is located behind clutch basket, you will need to take it off. Don't forget to buy new clutch cover gasket and coolant.
Replacement is pretty easy, took me 30-45min

Sent from my Redmi Note 8 Pro using Tapatalk
 

·
Registered
Joined
·
276 Posts
Discussion Starter #3
Thank you for your response! Sounds like something I could tackle. Did you order the new sensor online or just clean the contact points? Also, did you go ahead and replace your clutch plates since it was open? My bike has 68,000 miles so thinking I might as well replace them. I guess we are the only ones that have experienced this problem as I haven't seen any other responses.
 

·
Registered
Joined
·
15 Posts
Ordered new OEM sensor as it cost around 60€ or something like that. It's easier to replace with new one as clean old one and after a month anyway replace it.
Just sold my DL1000 with 130.000km. Did not replaced cluth plates, I'm sure they will last long time more.


Sent from my Redmi Note 8 Pro using Tapatalk
 

·
Registered
Joined
·
20 Posts
Gear indicator on my 2006 DL650 stopped working, displays an F instead of any gear. Just got the bike and it was that way already, PO said it just quit at some point and he hadn't gotten around to messing with trying to fix. Is that likely to be same problem? Have 64K miles on the bike.
 

·
Registered
Joined
·
276 Posts
Discussion Starter #6
Ordered new OEM sensor as it cost around 60€ or something like that. It's easier to replace with new one as clean old one and after a month anyway replace it.
Just sold my DL1000 with 130.000km. Did not replaced cluth plates, I'm sure they will last long time more.


Sent from my Redmi Note 8 Pro using Tapatalk
Thanks again for the reply! I will order a new one and hold off on replacing the plates. Appreciate your answer!
 

·
Registered
Joined
·
276 Posts
Discussion Starter #7
Gear indicator on my 2006 DL650 stopped working, displays an F instead of any gear. Just got the bike and it was that way already, PO said it just quit at some point and he hadn't gotten around to messing with trying to fix. Is that likely to be same problem? Have 64K miles on the bike.
Being a 650, I can't honestly say. I would definitely look at the parts fiche and see if it has the same gear position sensor as the DL1000. Also, ask in the 650 forum area if you haven't already. Good luck!
 
1 - 10 of 10 Posts
Top