StromTrooper banner

1 - 10 of 10 Posts

·
Registered
Joined
·
72 Posts
Discussion Starter #1
Hi guys,

Am I the only one with this problem?

Since my last maintenance (but possibly unrelated), my gear indicator has been having issues.

Mainly in 1st gear (but I've since noticed it in 2nd as well) it sometimes flickers between displaying 1st, 2nd and even 3rd gear (in 2nd, I've also seen 3rd displayed).

I asked my dealer, who also did the maintenance, what it could be, and he told me to clean the sensor (which is behind the front sprocket cover). I haven't got around to this, but has any of you guys experienced this?

Of course, if it turns out cleaning doesn't help, the sensor will be replaced in warranty, but... it's a bit of a hassle to ride to the dealer and back (he's an hour away).
 

·
Registered
Joined
·
47 Posts
A drag for sure.

Kind of reminds me of the old days, when there were no gear indicators and it was sound, feel, and memory.

I do have to say I like gear indicators though. Can be easier at red lights for sure.
 

·
Registered
Joined
·
50 Posts
"it was sound, feel, and memory."

Yah, imagine my surprise when I finally up shifted and found another gear...Doh!
Can you imagine my disappointment at not having seventh, pfft!:wink2:
 

·
Registered
Joined
·
72 Posts
Discussion Starter #6
So, back on topic, nobody else seems to have gear indicator issues 😉
 

·
Premium Member
Joined
·
2,236 Posts
So, back on topic, nobody else seems to have gear indicator issues 😉
Not true. '14 vstrom 1000 with 40000 miles. To date, no other issues at all with this bike. The erratic gear indicator problem began happening to me last summer. Dealer could not reproduce it this year at the time of inspection. I have ridden the bike sparingly over the past three weeks, and it has not happened - yet. Only thing different was an oil change before the season began. We shall see. Worst case scenario, the sensor has to be replaced. Shouldn't be a big deal.
 

·
Registered
Joined
·
4 Posts
Ive been getting it on my 2017 650 XT randomly the past few months. I havent found a fix and the dealer is 2 hours away so not worth the time imo.
 

·
Registered
Joined
·
72 Posts
Discussion Starter #9
Ive been getting it on my 2017 650 XT randomly the past few months. I havent found a fix and the dealer is 2 hours away so not worth the time imo.
It's getting worse, too. I noticed in fifth that it flickered to sixth today, hadn't seen that before.
 

·
Registered
Joined
·
129 Posts
I'd say it's worth a quick look at the switch and its wiring harness. Due to its close proximity to the front sprocket, debris from the chain, like a stick, could cause a problem. The old bakelite neutral light switches used to get broken simply by a loose chain, but running a stick through there really does the job.

The switch itself is a pretty simple deal, but routing the wires might be a task. As per usual, troubleshooting procedures may not prove out the intermittent problem. A dirty connection at the top, under the fuel tank, could easily give a confused reading, but it is not as likely as the bottom, where parts are exposed to the elements. DD
 
1 - 10 of 10 Posts
Top