StromTrooper banner

1 - 5 of 5 Posts

·
Registered
Joined
·
288 Posts
You should move/post this review in the section under the Maintenance, tech & farkles section where you will find a product review section
 

·
FORUM GODFATHER.....R.I.P. PAT
Joined
·
38,103 Posts
I moved it to the appropriate forum.
 

·
Registered
Joined
·
99 Posts
350 LM Charging Problem....help?

I have the Garmin 350LM and have it mounted to my Wee on a RAM mount on the Richland Rick mount under the windscreen. I have the unit powered/hardwired to my battery. During the first month or so that I owned the device it would charge while mounted on my bike. But now it has mysteriously stopped charging while mounted. It charges when I plug it into my computer when off the bike. But of course this does not help me when I am riding and wish to have the unit direct me for longer than the 2 or 3 hours of battery life! I have checked fuses (all ok), contact points are clean, wiring appears ok, battery connections are good. But I cannot find anything that seems to be responsible for the recent lack of charging capability. Could it be the 350LM unit itself? Any ideas?? Suggestions?? The GPS unit is over a year old now so no hope of any warranty support. Honestly, I think I have used the unit a total of about 8 hours while mounted on my bike without any problems until it just mysteriously stopped charging.
 

·
Registered
Joined
·
3,868 Posts
I have the Garmin 350LM and have it mounted to my Wee on a RAM mount on the Richland Rick mount under the windscreen. I have the unit powered/hardwired to my battery. During the first month or so that I owned the device it would charge while mounted on my bike. But now it has mysteriously stopped charging while mounted. It charges when I plug it into my computer when off the bike. But of course this does not help me when I am riding and wish to have the unit direct me for longer than the 2 or 3 hours of battery life! I have checked fuses (all ok), contact points are clean, wiring appears ok, battery connections are good. But I cannot find anything that seems to be responsible for the recent lack of charging capability. Could it be the 350LM unit itself? Any ideas?? Suggestions?? The GPS unit is over a year old now so no hope of any warranty support. Honestly, I think I have used the unit a total of about 8 hours while mounted on my bike without any problems until it just mysteriously stopped charging.
The first thing I would do is test for power at the cradle mounted on the bike but I would use a test light not a multi meter.

A multi meter does not require much power to give a indication and there could be a poor connection that will show a voltage but will not carry enough power to run the Gramin.

A test light will give a true power indication.

Even though it is a 5 volt power source a 12v test light will do.
 
1 - 5 of 5 Posts
Top