StromTrooper banner

1 - 7 of 7 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
I managed to damage the green slide lock that connects the fuel hose to the bottom of the tank.
It seems to function just fine at this point, but I would like to restore it without replacing the entire assembly.
One leg of the [ C ] shaped hasp has its tip missing,I cable tied it for a backup.
Any input? Thanks
 

·
Registered
Joined
·
2,705 Posts
Next time you take the tank of, remove the green part, go to the auto parts store and see if they don't have a connector with the same design and swap the green clamp out.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #4
The 2018 1000 has a different style connector than the one in post 2.
You pull a clip away from the hose and it slides off .
to replace , push it fully past the barb and return the clip into its slot.
Use your fingers, not long needle nose. Doh!

I have an upcoming trip, so I was hoping there was some research out there on this.I know if Mr Greywolf was still with us he would have a labeled picture, a schematic and a part #, I guess we will have to carry on , its no big deal until it lets loose out on the road, but I think it should hold with the tiewrap.
 

·
Registered
Joined
·
3,106 Posts
When I got my 2014 V2 that clip was damaged so I swapped it for another one on the bike that was only going to be used if I was to remove the throttle bodies.

I'm not sure if that will work on your bike.

On the V2 you don't remove the clip you just pop it up as you push back on the hose, there is a slot in the clip to fit the flat end of a screwdriver then twist.
 

·
Registered
Joined
·
689 Posts
When I had a problem with my fuel connecotr, I solved it with the fuel hose and two metal hose clamp:
I wouldn't trust that type of clamp. Go to NAPA or who ever & get the high pressure type of clamp.
I've had my tank off several times & the OE connector is a non-issue.
 
1 - 7 of 7 Posts
Top