StromTrooper banner

1 - 12 of 12 Posts

·
Registered
Joined
·
615 Posts
Discussion Starter #1
Had to put the bike in today to get the fuel sender unit replaced under warranty. Workshop manager said they have replaced a few under warranty, anyone else here had problems? Only symptom was the last bar of the LED display wouldn't show after filling up.
 

·
FORUM GODFATHER.....R.I.P. PAT
Joined
·
38,103 Posts
I've heard of poor connections causing problems, but not total part failure. I wonder if the act of removing the sender and connecting another cleared up a connection problem and the old sensor wasn't actually a problem. Did they test the old part?
 

·
Registered
Joined
·
15,501 Posts
Nice to get it fixed under warranty. Lots of us, it seems, have some error on our older bikes. My 04 Wee has the top bar indication occasionally not all the time. It's a non problem because all the other bars seems to indicate just fine.
 

·
Registered
Joined
·
195 Posts
On my 05, the top bar hasn't been on for the last couple years, it comes on at startup, but not with a full tank. I had it apart last weekend and while it was out of the tank I used some steel wool to clean up the contacts on the board that the float arm comes in contact with. They were a bit dirty and it seemed to do the trick. All bars on now when tank is full.
 

·
FORUM GODFATHER.....R.I.P. PAT
Joined
·
38,103 Posts
I don't like steel wool. There is a tendency for small particles to break off in use and fall in bad places or embed in the material to be cleaned and causing rust later. Never use it to clean stainless steel. It changes it to rusty steel. I prefer Scotch Brite pads, emery paper/cloth, grit impregnated rubber wheels or pencil erasers depending on job specifics.
 

·
Registered
Joined
·
615 Posts
Discussion Starter #6
Greywolf, it appears they did test the old unit. When I had the problem I mentioned in my post "One for the brains trust", I mentioned the last LED bar not showing to the dealer then and the reply was that it was a faulty sender unit. I had to wait for one to come from Japan, so the job is being done today. When I dropped the bike off, the workshop manager mentioned that he has done a few on the 2014+ Stroms. I figured the sender unit would be similar or identical in most of the later model Suzukis.
 

·
FORUM GODFATHER.....R.I.P. PAT
Joined
·
38,103 Posts
That may mean a rethink on problem is in order. The sender is basically a potentiometer like the TPS that has proved to have a wear problem.
 

·
Premium Member
Joined
·
174 Posts
That may mean a rethink on problem is in order. The sender is basically a potentiometer like the TPS that has proved to have a wear problem.
The TPS has a wear problem? Crap. Hadn't seen that. Must pay better attention. Is it just the 2014 bikes or does it affect all post '14?
 

·
FORUM GODFATHER.....R.I.P. PAT
Joined
·
38,103 Posts
All years and models have a possibility of TPS wear. It's one of the most common causes of failure to idle without dying.
 

·
Premium Member
Joined
·
174 Posts
All years nad models have a possibility of TPS wear. It's one of the most common causes of failure to idle without dying.
Yikes. Never even thought about it. Do you think there is any possibility of improvement in the new model or is it just a generic flaw in the design of any TPS?
 

·
FORUM GODFATHER.....R.I.P. PAT
Joined
·
38,103 Posts
The conductive coating on any potentiometer can wear out. The wear often is greatest in the most common position as the wiper sits in one place as the bike vibrates the wiper on the conductive surface.
 

·
Registered
Joined
·
7 Posts
Had to put the bike in today to get the fuel sender unit replaced under warranty. Workshop manager said they have replaced a few under warranty, anyone else here had problems? Only symptom was the last bar of the LED display wouldn't show after filling up.
My is a 2015 DL1000 with 8400 Kms, after not using the bike for at least 7 month, the fuel indicator was stuck in 5 bar out of 6, (aprox 3/4 full) I empty the tank and the bars came down to 3 (thats like half tank) I beleave the sender is miss reading the level. Going to have to change the sender. Quantum has complete kit with , pump, strainer, Orings, pressure accumulator, tank seal, etc for a reasonable price of 85$, but the sender it self cost 105$
 
1 - 12 of 12 Posts
Top