StromTrooper banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1,944 Posts
Discussion Starter #1
Well I went to pick up the GIVI Engine guards today , they were suprised to see me roll up on the V-STROM, but I unboxed the parts checked the fastners and spacer w/ the inventory sheet put the shrink wrap'd parcell on the seat & put the spider web net over it and rode 34 miles home to start the install. I will state now that EVEN THOUGH I am a male, :roll: I did follow the instruction's and everthing went perfectly :D .....except for the supplied spacer that rattles because the bolt is as tight as possible but the spacer is 5/16th's too short :x ( i don't know how many milimeters that is )
so I removed the spacer. :) I used locktite blue on all the fastners and :shock: even had an adapter for the right size metric allen to use on my torque wrench. :D
now I'm 140 sheckells safer for the farkle.... or is it 1 Farkle safer for only 140 sheckells.. 8) ... OH well, I did the install my self so that saved me sixty or so sheckles. Sorry I can't post photos as dial up takes forever. :oops: jack
 

·
Premium Member
Joined
·
4,406 Posts
Well done Jack. When I put the Givi guards on my '06 V, I put a considerable amount of silicone seal into the tubes before I installed the spacer and did up the bolt. Everything is fine, no vibes no loose parts. Just something to consider.
 

·
Registered
Joined
·
1,944 Posts
Discussion Starter #3
Thanks HEAVY, I 'm going to loosen up the bolt and seal it today. Ididn't think of that but I'm sure that without the sealant moisture would get inside. thanks for the suggestion. :) jack
 

·
Premium Member
Joined
·
4,406 Posts
I wasn't worried about the moisture, I knew about the thing being loose and was just helping it to stay in place.
 

·
Registered
Joined
·
1,944 Posts
Discussion Starter #5
OH, I was ok w/the barrel spacer between the l/r tubes thats tight in both tubes , Givi supplied a 3/4" long sleeve to act as a sort of spacer for the interconnect flanges on the tubes . thats what was rattling. I rode for 75 miles today to see if anything would loosen up :shock: . rechecked all the fastners/connections , I did seal the spacerw/Black sillycone sealant.
I also ordered DSL today so maybe soon I can post pics. :!: does DSL COUNT AS A FARKLE :? Thanks for the insights....ride often & ride safe...jack 8)
 

·
Registered
Joined
·
1,944 Posts
Discussion Starter #6
OK Now thatI have the engine guards done, I started on an adapter plate for the used top box I picked up at a yard sale. $ 5.oo for a box w/o keys or brackets. I removed the rubber cover on the parcel rack, Layed over a piece of 1/16"
plexi , did a black marker outline.Recipro saw w 24tpi to rough out the shape & a 3/16" drill bit in the cordless to pilot drill the mount holes.
Next I tapped the 5 holes in the parcel rack for 3/8-24. drilled the pilot holes to 7/16" & transfered the overall shape & drilled holes to the $2.99. 12" x 18" black nylon cutting board from BIG LOTS. tested the fit up and found it to be good then I set the topbox and checked the allignment and marked the plate for transfer of bolt holes to the box.. :) . OK, heres where the wheels came off ...... I didn't set the box far enough back . Sooooo I couldn't , are you ready for this........ remove the seat . :x ... I had to re-drill new Holes and check it all again. EUREKA, it works . :D .....total cost (after sealant to fill 4 holes no longer needed ) was 15.98... box is large enough for My helmet, gloves & riding pants . I'm OK with that..... :wink:
 

·
Registered
Joined
·
1,944 Posts
Discussion Starter #8
After reading my own post I may spend som of my farkl munny for typing tutorial.... :wink:
 
1 - 8 of 8 Posts
Top